summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-09-10 19:22:45 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-09-10 19:22:45 +0000
commit383fb102e952c802f49a039eadb8ebe7ca8ec6b5 (patch)
tree7576af5b0adc53ab4325dccf3670b5bdd1643417 /dev-dotnet
parentstable on x86, wrt bug #191127 (diff)
downloadgentoo-2-383fb102e952c802f49a039eadb8ebe7ca8ec6b5.tar.gz
gentoo-2-383fb102e952c802f49a039eadb8ebe7ca8ec6b5.tar.bz2
gentoo-2-383fb102e952c802f49a039eadb8ebe7ca8ec6b5.zip
dev-dotnet/taglib-sharp: version bump (bug #191998)
(Portage version: 2.1.2.12)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/taglib-sharp/ChangeLog8
-rw-r--r--dev-dotnet/taglib-sharp/files/digest-taglib-sharp-1.9.754743
-rw-r--r--dev-dotnet/taglib-sharp/taglib-sharp-1.9.75474.ebuild42
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-dotnet/taglib-sharp/ChangeLog b/dev-dotnet/taglib-sharp/ChangeLog
index d3463a14575c..02086f606b9c 100644
--- a/dev-dotnet/taglib-sharp/ChangeLog
+++ b/dev-dotnet/taglib-sharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/taglib-sharp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/ChangeLog,v 1.2 2007/07/04 21:04:21 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/ChangeLog,v 1.3 2007/09/10 19:22:45 jurek Exp $
+
+*taglib-sharp-1.9.75474 (10 Sep 2007)
+
+ 10 Sep 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +taglib-sharp-1.9.75474.ebuild:
+ Version bump (bug #191998)
*taglib-sharp-1.1.73998-r1 (04 Jul 2007)
diff --git a/dev-dotnet/taglib-sharp/files/digest-taglib-sharp-1.9.75474 b/dev-dotnet/taglib-sharp/files/digest-taglib-sharp-1.9.75474
new file mode 100644
index 000000000000..d0673ce7d59e
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/files/digest-taglib-sharp-1.9.75474
@@ -0,0 +1,3 @@
+MD5 e1afbb9083163db4933ad37501e5c18f taglib-sharp-1.9.75474.tar.gz 1802343
+RMD160 20cccb90a8c7123f60206953d281d6a4b72dd35a taglib-sharp-1.9.75474.tar.gz 1802343
+SHA256 154bff41eec986aa20a151af143dc417fb9f394111ff54172b35f0ed75f8f154 taglib-sharp-1.9.75474.tar.gz 1802343
diff --git a/dev-dotnet/taglib-sharp/taglib-sharp-1.9.75474.ebuild b/dev-dotnet/taglib-sharp/taglib-sharp-1.9.75474.ebuild
new file mode 100644
index 000000000000..0ceeb1b2ed5f
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/taglib-sharp-1.9.75474.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/taglib-sharp-1.9.75474.ebuild,v 1.1 2007/09/10 19:22:45 jurek Exp $
+
+inherit mono eutils
+
+DESCRIPTION="Taglib C# binding"
+HOMEPAGE="http://developer.novell.com/wiki/index.php/TagLib_Sharp"
+SRC_URI="http://developer.novell.com/wiki/index.php/Special:File/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-1.1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.9
+ app-arch/unzip )
+ media-libs/taglib"
+
+src_compile() {
+ # taglib-sharp configure script is a bit messed up
+ if use doc; then
+ econf $(use_with doc docs) || die "configure failed"
+ else
+ econf $(use_enable doc docs) || die "configure failed"
+ fi
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ # cleaning up docdir mess (bug #184149)
+ sed -i -e 's#^docdir = ${datarootdir}/doc/${PACKAGE}$##' \
+ -e 's#^docdir = $(DESTDIR)$(DOCDIR)$#docdir = $(DOCDIR)#' \
+ docs/Makefile \
+ || die "sed failed"
+
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}