summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2011-03-01 08:06:42 +0000
committerAlistair Bush <ali_bush@gentoo.org>2011-03-01 08:06:42 +0000
commit74e66fecd7d202c41536d739ea3146b5da6700fd (patch)
tree20bc2e778195c1cefcf8a53859547eeface62795 /dev-dotnet/mono-addins
parent[bump] virtual/perl-ExtUtils-Command-1.170.0 (diff)
downloadgentoo-2-74e66fecd7d202c41536d739ea3146b5da6700fd.tar.gz
gentoo-2-74e66fecd7d202c41536d739ea3146b5da6700fd.tar.bz2
gentoo-2-74e66fecd7d202c41536d739ea3146b5da6700fd.zip
Version Bump.
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/mono-addins')
-rw-r--r--dev-dotnet/mono-addins/ChangeLog9
-rw-r--r--dev-dotnet/mono-addins/mono-addins-0.6.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-dotnet/mono-addins/ChangeLog b/dev-dotnet/mono-addins/ChangeLog
index 3b7dc14efb1f..d64a3e0ef41f 100644
--- a/dev-dotnet/mono-addins/ChangeLog
+++ b/dev-dotnet/mono-addins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/mono-addins
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/ChangeLog,v 1.22 2010/10/07 19:47:02 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/ChangeLog,v 1.23 2011/03/01 08:06:42 ali_bush Exp $
+
+*mono-addins-0.6 (01 Mar 2011)
+
+ 01 Mar 2011; Alistair Bush <ali_bush@gentoo.org> +mono-addins-0.6.ebuild:
+ Version Bump.
07 Oct 2010; Pacho Ramos <pacho@gentoo.org>
-files/mono-addins-0.2-disable-gui.patch, -mono-addins-0.3.ebuild,
diff --git a/dev-dotnet/mono-addins/mono-addins-0.6.ebuild b/dev-dotnet/mono-addins/mono-addins-0.6.ebuild
new file mode 100644
index 000000000000..979279fff705
--- /dev/null
+++ b/dev-dotnet/mono-addins/mono-addins-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/mono-addins-0.6.ebuild,v 1.1 2011/03/01 08:06:42 ali_bush Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="A generic framework for creating extensible applications"
+HOMEPAGE="http://www.mono-project.com/Mono.Addins"
+SRC_URI="http://go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+gtk"
+
+RDEPEND=">=dev-lang/mono-2
+ gtk? ( >=dev-dotnet/gtk-sharp-2.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19"
+
+src_configure() {
+ econf $(use_enable gtk gui)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+ mono_multilib_comply
+}