summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-10 10:33:47 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-10 10:33:47 +0000
commitdee9f195b75d68d68195331ab4fe7cf6021123b6 (patch)
treeb9417b93800dc34740a681e889ce7c5f711962ae /dev-dotnet/ikvm
parentRemove old. (diff)
downloadgentoo-2-dee9f195b75d68d68195331ab4fe7cf6021123b6.tar.gz
gentoo-2-dee9f195b75d68d68195331ab4fe7cf6021123b6.tar.bz2
gentoo-2-dee9f195b75d68d68195331ab4fe7cf6021123b6.zip
Version bump, remove old.
(Portage version: 2.1.10.14/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/ikvm')
-rw-r--r--dev-dotnet/ikvm/ChangeLog10
-rw-r--r--dev-dotnet/ikvm/files/ikvm-0.46.0.1-key.patch61
-rw-r--r--dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild (renamed from dev-dotnet/ikvm/ikvm-0.44.0.5.ebuild)16
3 files changed, 77 insertions, 10 deletions
diff --git a/dev-dotnet/ikvm/ChangeLog b/dev-dotnet/ikvm/ChangeLog
index b7fc3eac23e8..da0bd44520af 100644
--- a/dev-dotnet/ikvm/ChangeLog
+++ b/dev-dotnet/ikvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/ikvm
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm/ChangeLog,v 1.25 2010/12/06 14:09:34 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm/ChangeLog,v 1.26 2011/09/10 10:33:47 pacho Exp $
+
+*ikvm-0.46.0.1 (10 Sep 2011)
+
+ 10 Sep 2011; Pacho Ramos <pacho@gentoo.org> -ikvm-0.44.0.5.ebuild,
+ +ikvm-0.46.0.1.ebuild, +files/ikvm-0.46.0.1-key.patch:
+ Version bump, remove old.
*ikvm-0.44.0.6 (06 Dec 2010)
diff --git a/dev-dotnet/ikvm/files/ikvm-0.46.0.1-key.patch b/dev-dotnet/ikvm/files/ikvm-0.46.0.1-key.patch
new file mode 100644
index 000000000000..cd45f6bf0da3
--- /dev/null
+++ b/dev-dotnet/ikvm/files/ikvm-0.46.0.1-key.patch
@@ -0,0 +1,61 @@
+Author: Jo Shields
+Description: This patch ensures that rather than trying to use the Mono Crypto
+Description: Service Provider to retrieve a signing key (CSP is not safe to
+Description: run with fakeroot), we simply hard-code the path to a bundled key
+Description: file
+Index: ikvm/ikvm-0.46.0.1/CommonAssemblyInfo.cs.in
+===================================================================
+--- ikvm.orig/ikvm-0.46.0.1/CommonAssemblyInfo.cs.in 2011-07-05 01:24:45.000000000 +0100
++++ ikvm/ikvm-0.46.0.1/CommonAssemblyInfo.cs.in 2011-07-05 01:28:22.000000000 +0100
+@@ -33,5 +33,6 @@
+
+ #if SIGNCODE
+ #pragma warning disable 1699
+- [assembly: AssemblyKeyName("ikvm-key")]
++ [assembly: AssemblyDelaySign(false)]
++ [assembly: AssemblyKeyFile("../mono.snk")]
+ #endif
+Index: ikvm/ikvm-0.46.0.1/ikvm.build
+===================================================================
+--- ikvm.orig/ikvm-0.46.0.1/ikvm.build 2011-07-05 01:24:45.000000000 +0100
++++ ikvm/ikvm-0.46.0.1/ikvm.build 2011-07-05 01:33:07.000000000 +0100
+@@ -6,8 +6,8 @@
+ </target>
+ <target name="signed">
+ <property name="signed" value="SIGNCODE" />
+- <property name="signoption" value="-key:ikvm-key" />
+- <property name="ilasm_signoption" value="/key:@ikvm-key" />
++ <property name="signoption" value="-keyfile:../mono.snk" />
++ <property name="ilasm_signoption" value="/key:../mono.snk" />
+ <call target="managed" />
+ </target>
+ <target name="managed" depends="clean-managed CommonAssemblyInfo">
+Index: ikvm/ikvm-0.46.0.1/runtime/runtime.build
+===================================================================
+--- ikvm.orig/ikvm-0.46.0.1/runtime/runtime.build 2011-07-05 01:24:45.000000000 +0100
++++ ikvm/ikvm-0.46.0.1/runtime/runtime.build 2011-07-05 01:32:53.000000000 +0100
+@@ -7,8 +7,8 @@
+ </target>
+ <target name="signed">
+ <property name="signed" value="SIGNCODE" />
+- <property name="signoption" value="-key:ikvm-key" />
+- <property name="ilasm_signoption" value="/key:@ikvm-key" />
++ <property name="signoption" value="-keyfile:../../mono.snk" />
++ <property name="ilasm_signoption" value="/key:../../mono.snk" />
+ <call target="IKVM.Runtime" />
+ </target>
+
+Index: ikvm/ikvm-0.46.0.1/tools/pubkey.cs
+===================================================================
+--- ikvm.orig/ikvm-0.46.0.1/tools/pubkey.cs 2011-07-05 01:24:45.000000000 +0100
++++ ikvm/ikvm-0.46.0.1/tools/pubkey.cs 2011-07-05 01:28:22.000000000 +0100
+@@ -29,7 +29,8 @@
+
+ #if SIGNCODE
+ #pragma warning disable 1699
+- [assembly: AssemblyKeyName("ikvm-key")]
++ [assembly: AssemblyDelaySign(false)]
++ [assembly: AssemblyKeyFile("../mono.snk")]
+ #endif
+
+ class PublicKey
diff --git a/dev-dotnet/ikvm/ikvm-0.44.0.5.ebuild b/dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild
index 73b91c670d7c..3ba267100304 100644
--- a/dev-dotnet/ikvm/ikvm-0.44.0.5.ebuild
+++ b/dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm/ikvm-0.44.0.5.ebuild,v 1.1 2010/09/12 17:16:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild,v 1.1 2011/09/10 10:33:47 pacho Exp $
-EAPI=2
+EAPI="4"
inherit eutils mono multilib java-pkg-2
DESCRIPTION="Java VM for .NET"
-HOMEPAGE="http://www.ikvm.net/"
-SRC_URI="mirror://sourceforge/${PN}/openjdk6-b18-stripped.zip
- mirror://sourceforge/${PN}/${PN}src-${PV}.zip"
+HOMEPAGE="http://www.ikvm.net/ http://weblog.ikvm.net/"
+SRC_URI="http://www.frijters.net/openjdk6-b22-stripped.zip
+ http://www.frijters.net/${PN}src-${PV}.zip"
LICENSE="as-is"
SLOT="0"
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
src_prepare() {
# We cannot rely on Mono Crypto Service Provider as it doesn't work inside
# sandbox, we simply hard-code the path to a bundled key like Debian does.
- epatch "${FILESDIR}"/${PN}-0.44.0.5-key.patch
+ epatch "${FILESDIR}"/${PN}-0.46.0.1-key.patch
uudecode < "${FILESDIR}"/mono.snk.uu || die
# Ensures that we use Mono's bundled copy of SharpZipLib instead of relying
@@ -75,7 +75,7 @@ generate_pkgconfig() {
src_install() {
local dll dllbase exe
insinto /usr/$(get_libdir)/${PN}
- doins bin/*.exe bin/*.so || die
+ doins bin/*.exe
dodir /bin
for exe in bin/*.exe