summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2014-04-04 08:24:25 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2014-04-04 08:24:25 +0000
commite687b85ffade7cdfc08686b0658eb28935c3b00b (patch)
tree7699688befcac8306033cfedced1fd5b5d16f261 /dev-db
parent+oracle-instantclient-sqlplus-11.2.0.4: Revbump. Add RESTRICT=splitdebug. (diff)
downloadgentoo-2-e687b85ffade7cdfc08686b0658eb28935c3b00b.tar.gz
gentoo-2-e687b85ffade7cdfc08686b0658eb28935c3b00b.tar.bz2
gentoo-2-e687b85ffade7cdfc08686b0658eb28935c3b00b.zip
+oracle-instantclient-odbc-11.2.0.4: Revbump. Convert to USE abi_x86_*, bug#506228.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A630CCB8)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/oracle-instantclient-odbc/ChangeLog10
-rw-r--r--dev-db/oracle-instantclient-odbc/oracle-instantclient-odbc-11.2.0.4.ebuild97
2 files changed, 105 insertions, 2 deletions
diff --git a/dev-db/oracle-instantclient-odbc/ChangeLog b/dev-db/oracle-instantclient-odbc/ChangeLog
index 02f382f22c87..166f46c76c1f 100644
--- a/dev-db/oracle-instantclient-odbc/ChangeLog
+++ b/dev-db/oracle-instantclient-odbc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/oracle-instantclient-odbc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-odbc/ChangeLog,v 1.13 2012/11/15 19:52:17 haubi Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-odbc/ChangeLog,v 1.14 2014/04/04 08:24:25 haubi Exp $
+
+*oracle-instantclient-odbc-11.2.0.4 (04 Apr 2014)
+
+ 04 Apr 2014; Michael Haubenwallner <haubi@gentoo.org>
+ +oracle-instantclient-odbc-11.2.0.4.ebuild:
+ Revbump. Convert to USE abi_x86_*, bug#506228.
15 Nov 2012; Michael Haubenwallner <haubi@gentoo.org>
oracle-instantclient-odbc-11.2.0.3.ebuild:
diff --git a/dev-db/oracle-instantclient-odbc/oracle-instantclient-odbc-11.2.0.4.ebuild b/dev-db/oracle-instantclient-odbc/oracle-instantclient-odbc-11.2.0.4.ebuild
new file mode 100644
index 000000000000..2e24e8756407
--- /dev/null
+++ b/dev-db/oracle-instantclient-odbc/oracle-instantclient-odbc-11.2.0.4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-odbc/oracle-instantclient-odbc-11.2.0.4.ebuild,v 1.1 2014/04/04 08:24:25 haubi Exp $
+
+EAPI="4"
+
+inherit eutils multilib-minimal
+
+MY_PLAT_x86="Linux x86"
+MY_A_x86="${PN/oracle-/}-linux-${PV}.0.zip"
+
+MY_PLAT_amd64="Linux x86-64"
+MY_A_amd64="${PN/oracle-/}-linux.x64-${PV}.0.zip"
+
+DESCRIPTION="Oracle 11g Instant Client: ODBC supplement"
+HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
+SRC_URI="
+ abi_x86_32? ( ${MY_A_x86} )
+ abi_x86_64? ( ${MY_A_amd64} )
+"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch splitdebug"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/lib*/oracle/${PV}/client/lib*/lib*"
+
+set_my_abivars() {
+ MY_PLAT=MY_PLAT_${ABI}; MY_PLAT=${!MY_PLAT} # platform name
+ MY_A=MY_A_${ABI} ; MY_A=${!MY_A} # runtime distfile
+ # ABI sourcedir
+ MY_S="${S}/${ABI}/instantclient_11_2"
+
+ [[ -n ${MY_PLAT} ]]
+}
+
+pkg_nofetch() {
+ eerror "Please go to"
+ eerror " ${HOMEPAGE%/*}/index-097480.html"
+ eerror " and download"
+ local ABI
+ for ABI in $(multilib_get_enabled_abis)
+ do
+ set_my_abivars || continue
+ eerror "Instant Client for ${MY_PLAT}"
+ eerror " ODBC: ${MY_A}"
+ done
+ eerror "After downloading, put them in:"
+ eerror " ${DISTDIR}/"
+}
+
+src_unpack() {
+ local ABI
+ for ABI in $(multilib_get_enabled_abis)
+ do
+ set_my_abivars || continue
+ mkdir -p "${MY_S%/*}" || die
+ cd "${MY_S%/*}" || die
+ unpack ${MY_A}
+ done
+}
+
+src_install() {
+ # all binaries go here
+ local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client
+ into "${oracle_home}"
+
+ local ABI
+ for ABI in $(multilib_get_enabled_abis)
+ do
+ if ! set_my_abivars; then
+ elog "Skipping unsupported ABI ${ABI}."
+ continue
+ fi
+ einfo "Installing runtime for ${MY_PLAT} ..."
+
+ cd "${MY_S}" || die
+
+ dolib.so libsqora*$(get_libname)*
+
+ # ensure to be linkable
+ [[ -e libsqora$(get_libname) ]] ||
+ dosym libsqora$(get_libname 11.1) "${oracle_home}"/$(get_libdir)/libsqora$(get_libname)
+
+ eend $?
+ done
+
+ dobin odbc_update_ini.sh
+ dodoc *htm*
+}