summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-24 06:43:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-24 06:43:50 +0000
commitac5f87aec37bd36223c1d3f785432048782c0dc8 (patch)
tree75f80cbbc06a7e9be38c9bd37ef82d8f3de71e70 /dev-db
parentInitial commit, ebuild by me (diff)
downloadgentoo-2-ac5f87aec37bd36223c1d3f785432048782c0dc8.tar.gz
gentoo-2-ac5f87aec37bd36223c1d3f785432048782c0dc8.tar.bz2
gentoo-2-ac5f87aec37bd36223c1d3f785432048782c0dc8.zip
Bump
(Portage version: 2.2.0_alpha160/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/hyperdex/ChangeLog9
-rw-r--r--dev-db/hyperdex/hyperdex-1.0_rc1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-db/hyperdex/ChangeLog b/dev-db/hyperdex/ChangeLog
index ed352722dce1..137ce741f9b2 100644
--- a/dev-db/hyperdex/ChangeLog
+++ b/dev-db/hyperdex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/hyperdex
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.4 2012/08/20 13:33:23 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.5 2013/01/24 06:43:50 patrick Exp $
+
+*hyperdex-1.0_rc1 (24 Jan 2013)
+
+ 24 Jan 2013; Patrick Lauer <patrick@gentoo.org> +hyperdex-1.0_rc1.ebuild:
+ Bump
20 Aug 2012; Patrick Lauer <patrick@gentoo.org> hyperdex-0.4.0.ebuild:
... and clean up the python bits
diff --git a/dev-db/hyperdex/hyperdex-1.0_rc1.ebuild b/dev-db/hyperdex/hyperdex-1.0_rc1.ebuild
new file mode 100644
index 000000000000..d16f9577f3e0
--- /dev/null
+++ b/dev-db/hyperdex/hyperdex-1.0_rc1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.0_rc1.ebuild,v 1.1 2013/01/24 06:43:50 patrick Exp $
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+inherit eutils python
+
+DESCRIPTION="A searchable distributed Key-Value Store"
+
+MY_P="${P/_/.}"
+S="${WORKDIR}/${MY_P}"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+python"
+# need to add coverage and java useflags too
+
+DEPEND="dev-cpp/glog
+ dev-libs/cityhash
+ dev-libs/libpo6
+ dev-libs/libe
+ dev-libs/busybee
+ dev-libs/popt
+ dev-libs/replicant"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+}