summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-12-28 20:53:39 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-12-28 20:53:39 +0000
commitaa577ca8a94ae5bfb22876af52608a4de6a21fbb (patch)
treee3e38c49a6a5e879cc87d95d2b232f9112ebe5ce /dev-db
parentFixed build issue without geoip, bug #252811, thank Mike Auty for report. (diff)
downloadgentoo-2-aa577ca8a94ae5bfb22876af52608a4de6a21fbb.tar.gz
gentoo-2-aa577ca8a94ae5bfb22876af52608a4de6a21fbb.tar.bz2
gentoo-2-aa577ca8a94ae5bfb22876af52608a4de6a21fbb.zip
Added dev-db/phpmyadmin-2.11.9.4, -3.1.1 in response to #250752. Fixed #251070.
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog10
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.11.9.4.ebuild63
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-3.1.1.ebuild (renamed from dev-db/phpmyadmin/phpmyadmin-3.0.1.1.ebuild)6
3 files changed, 75 insertions, 4 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 8e31755b740b..c8b800e5819d 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.349 2008/12/07 07:42:35 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.350 2008/12/28 20:53:39 wrobel Exp $
+
+*phpmyadmin-3.1.1 (28 Dec 2008)
+*phpmyadmin-2.11.9.4 (28 Dec 2008)
+
+ 28 Dec 2008; Gunnar Wrobel <wrobel@gentoo.org>
+ +phpmyadmin-2.11.9.4.ebuild, -phpmyadmin-3.0.1.1.ebuild,
+ +phpmyadmin-3.1.1.ebuild:
+ Added dev-db/phpmyadmin-2.11.9.4, -3.1.1 in response to #250752. Fixed #251070.
07 Dec 2008; Gunnar Wrobel <wrobel@gentoo.org> phpmyadmin-3.0.1.1.ebuild:
Fixed mysql dependency (#248623).
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.11.9.4.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.11.9.4.ebuild
new file mode 100644
index 000000000000..0580c48efd0d
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.11.9.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.11.9.4.ebuild,v 1.1 2008/12/28 20:53:39 wrobel Exp $
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages-utf-8-only"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use crypt ctype pcre session unicode \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "crypt ctype pcre session unicode"
+ eerror
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "mysql or mysqli if using dev-lang/php-5"
+ eerror
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.11.5-custom-cert.patch
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog
+ rm -f LICENSE CREDITS INSTALL README RELEASE-DATE-${MY_PV} TODO
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.8.0.txt
+ webapp_hook_script "${FILESDIR}"/reconfig-2.8
+ webapp_src_install
+}
diff --git a/dev-db/phpmyadmin/phpmyadmin-3.0.1.1.ebuild b/dev-db/phpmyadmin/phpmyadmin-3.1.1.ebuild
index 94ec43a21619..151fe0f1961e 100644
--- a/dev-db/phpmyadmin/phpmyadmin-3.0.1.1.ebuild
+++ b/dev-db/phpmyadmin/phpmyadmin-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.0.1.1.ebuild,v 1.2 2008/12/07 07:42:35 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.1.1.ebuild,v 1.1 2008/12/28 20:53:39 wrobel Exp $
inherit eutils webapp depend.php
@@ -25,13 +25,13 @@ S="${WORKDIR}"/${MY_P}
pkg_setup() {
webapp_pkg_setup
- if ! PHPCHECKNODIE="yes" require_php_with_use crypt ctype pcre session unicode \
+ if ! PHPCHECKNODIE="yes" require_php_with_use crypt ctype pcre session spl unicode \
|| ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ; then
eerror
eerror "${PHP_PKG} needs to be re-installed with all of the following"
eerror "USE flags enabled:"
eerror
- eerror "ctype pcre session unicode"
+ eerror "crypt ctype pcre session spl unicode"
eerror
eerror "as well as any of the following USE flags enabled:"
eerror