summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-01 21:27:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-01 21:27:03 +0000
commit2f67657236140042d7da9c3702fbc03ea99a2f51 (patch)
tree8db44bada46556752930e98689a010c9accd53b4 /dev-db
parentClean up old ebuilds and make repoman happy. (diff)
downloadgentoo-2-2f67657236140042d7da9c3702fbc03ea99a2f51.tar.gz
gentoo-2-2f67657236140042d7da9c3702fbc03ea99a2f51.tar.bz2
gentoo-2-2f67657236140042d7da9c3702fbc03ea99a2f51.zip
mysql_config did not return correct output, per bug #224451. Revision bump with a fix.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog9
-rw-r--r--dev-db/mysql/mysql-5.0.60-r1.ebuild104
2 files changed, 112 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 5d3170dc6a0c..37c475e1d6ea 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.452 2008/05/29 19:54:19 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.453 2008/06/01 21:27:03 robbat2 Exp $
+
+*mysql-5.0.60-r1 (01 Jun 2008)
+
+ 01 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +mysql-5.0.60-r1.ebuild:
+ mysql_config did not return correct output, per bug #224451. Revision bump
+ with a fix.
29 May 2008; Robin H. Johnson <robbat2@gentoo.org> mysql-4.0.27-r1.ebuild,
mysql-4.1.22-r1.ebuild:
diff --git a/dev-db/mysql/mysql-5.0.60-r1.ebuild b/dev-db/mysql/mysql-5.0.60-r1.ebuild
new file mode 100644
index 000000000000..72b2bec7ccec
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.60-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.60-r1.ebuild,v 1.1 2008/06/01 21:27:03 robbat2 Exp $
+
+MY_EXTRAS_VER="20080601"
+SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # archive_gis really sucks a lot, but it's only relevant for the
+ # USE=extraengines case
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Totally broken in 5.0.42"
+ ;;
+
+ 5.0.44|5.0.45|5.0.46|5.0.48|5.0.5[0-6]*)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test \
+ "archive_gis" \
+ "Broken in 5.0.44-56 on big-endian boxes only"
+ ;;
+ esac
+
+ # This was a slight testcase breakage when the read_only security issue
+ # was fixed.
+ case ${PV} in
+ 5.0.54|5.0.51*)
+ mysql_disable_test \
+ "read_only" \
+ "Broken in 5.0.51-54, output in wrong order"
+ ;;
+ esac
+
+ # Ditto to read_only
+ [ "${PV}" == "5.0.51a" ] && \
+ mysql_disable_test \
+ "view" \
+ "Broken in 5.0.51, output in wrong order"
+
+ # x86-specific, OOM issue with some subselects on low memory servers
+ [ "${PV}" == "5.0.54" ] && \
+ [ "${ARCH/x86}" != "${ARCH}" ] && \
+ mysql_disable_test \
+ "subselect" \
+ "Testcase needs tuning on x86 for oom condition"
+
+ # Broke with the YaSSL security issue that didn't affect Gentoo.
+ [ "${PV}" == "5.0.56" ] && \
+ for t in openssl_1 rpl_openssl rpl_ssl ssl \
+ ssl_8k_key ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "OpenSSL tests broken on 5.0.56"
+ done
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
+
+ # We run the test protocols seperately
+ make -j1 test-ns force="--force --vardir=${S}/mysql-test/var-ns"
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force="--force --vardir=${S}/mysql-test/var-ps"
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ einfo "Tests successfully completed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}