summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2009-05-28 20:37:25 +0000
committerFerris McCormick <fmccor@gentoo.org>2009-05-28 20:37:25 +0000
commit227129cc09377c1a4d9ab5014f224951782a1c23 (patch)
tree4a1c3f94fc0cfbdcd786c1f01e6f45a40586972d /dev-db
parentgive up the package to some people that want it (diff)
downloadgentoo-2-227129cc09377c1a4d9ab5014f224951782a1c23.tar.gz
gentoo-2-227129cc09377c1a4d9ab5014f224951782a1c23.tar.bz2
gentoo-2-227129cc09377c1a4d9ab5014f224951782a1c23.zip
Re-add the patch without the header change.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch30
2 files changed, 5 insertions, 31 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 18c607e71858..09f242f5dcdd 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.251 2009/05/28 17:53:24 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.252 2009/05/28 20:37:25 fmccor Exp $
+
+ 28 May 2009; Ferris McCormick <fmccor@gentoo.org>
+ -files/sqlite-3.6.14.2-fix_alignment.patch:
+ Re-add the patch without the header change.
28 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
sqlite-3.6.14.2.ebuild, +files/sqlite-3.6.14.2-fix_alignment.patch:
diff --git a/dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch b/dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch
deleted file mode 100644
index fe7ee13bc7a4..000000000000
--- a/dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/rowset.c
-+++ src/rowset.c
-@@ -60,7 +60,7 @@
- ** There is an added cost of O(N) when switching between TEST and
- ** SMALLEST primitives.
- **
--** $Id: rowset.c,v 1.6 2009/04/22 15:32:59 drh Exp $
-+** $Id: rowset.c,v 1.7 2009/05/22 01:00:13 drh Exp $
- */
- #include "sqliteInt.h"
-
-@@ -127,15 +127,15 @@
- */
- RowSet *sqlite3RowSetInit(sqlite3 *db, void *pSpace, unsigned int N){
- RowSet *p;
-- assert( N >= sizeof(*p) );
-+ assert( N >= ROUND8(sizeof(*p)) );
- p = pSpace;
- p->pChunk = 0;
- p->db = db;
- p->pEntry = 0;
- p->pLast = 0;
- p->pTree = 0;
-- p->pFresh = (struct RowSetEntry*)&p[1];
-- p->nFresh = (u16)((N - sizeof(*p))/sizeof(struct RowSetEntry));
-+ p->pFresh = (struct RowSetEntry*)(ROUND8(sizeof(*p)) + (char*)p);
-+ p->nFresh = (u16)((N - ROUND8(sizeof(*p)))/sizeof(struct RowSetEntry));
- p->isSorted = 1;
- p->iBatch = 0;
- return p;