summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-02-19 08:27:18 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-02-19 08:27:18 +0000
commit1c1a25515b9e32ef873f2c06b9b524c218950b77 (patch)
tree712d7dd03ecdf74f13ddc35ae024994201217cfe /dev-db
parentversion bump as per bug #167535 thanks to dev-zero (diff)
downloadgentoo-2-1c1a25515b9e32ef873f2c06b9b524c218950b77.tar.gz
gentoo-2-1c1a25515b9e32ef873f2c06b9b524c218950b77.tar.bz2
gentoo-2-1c1a25515b9e32ef873f2c06b9b524c218950b77.zip
Fix compilation for bug #151553. Rewrite ebuild to use epatch and other
eutils helpers. (Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/framerd/ChangeLog10
-rw-r--r--dev-db/framerd/files/digest-framerd-2.4.3-r12
-rw-r--r--dev-db/framerd/files/framerd-2.4.3-gcc41.patch22
-rw-r--r--dev-db/framerd/files/framerd-2.4.3-setup.fdx.patch14
-rw-r--r--dev-db/framerd/files/setup.fdx.patch6
-rw-r--r--dev-db/framerd/framerd-2.4.3-r1.ebuild28
6 files changed, 63 insertions, 19 deletions
diff --git a/dev-db/framerd/ChangeLog b/dev-db/framerd/ChangeLog
index b5f84a75c7ea..42b688346804 100644
--- a/dev-db/framerd/ChangeLog
+++ b/dev-db/framerd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/framerd
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/framerd/ChangeLog,v 1.14 2006/04/01 14:29:56 agriffis Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/framerd/ChangeLog,v 1.15 2007/02/19 08:27:18 dirtyepic Exp $
+
+ 19 Feb 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/framerd-2.4.3-gcc41.patch, +files/framerd-2.4.3-setup.fdx.patch,
+ -files/setup.fdx.patch, framerd-2.4.3-r1.ebuild:
+ Fix compilation for bug #151553. Rewrite ebuild to use epatch and other
+ eutils helpers.
01 Apr 2006; Aron Griffis <agriffis@gentoo.org> framerd-2.4.3-r1.ebuild:
Mark 2.4.3-r1 ~ia64
diff --git a/dev-db/framerd/files/digest-framerd-2.4.3-r1 b/dev-db/framerd/files/digest-framerd-2.4.3-r1
index c1f78b76707a..3462e7d072ae 100644
--- a/dev-db/framerd/files/digest-framerd-2.4.3-r1
+++ b/dev-db/framerd/files/digest-framerd-2.4.3-r1
@@ -1 +1,3 @@
MD5 ad493f56f5dbcb6cbff9f6e29a3dfdfe framerd-2.4.3.tar.gz 1685197
+RMD160 85aec71a7bcec6fe259d541b3f4c125aea8d70c6 framerd-2.4.3.tar.gz 1685197
+SHA256 c4a8c2c5814179da879c7ed76f17f1d676b97ee297d9ec4ff5fabb92cc63d988 framerd-2.4.3.tar.gz 1685197
diff --git a/dev-db/framerd/files/framerd-2.4.3-gcc41.patch b/dev-db/framerd/files/framerd-2.4.3-gcc41.patch
new file mode 100644
index 000000000000..a124e240c097
--- /dev/null
+++ b/dev-db/framerd/files/framerd-2.4.3-gcc41.patch
@@ -0,0 +1,22 @@
+diff -Naur framerd-2.4.3-orig/include/framerd/odb.h framerd-2.4.3/include/framerd/odb.h
+--- framerd-2.4.3-orig/include/framerd/odb.h 2002-07-23 20:05:47.000000000 -0600
++++ framerd-2.4.3/include/framerd/odb.h 2007-02-19 02:06:30.000000000 -0600
+@@ -139,6 +139,7 @@
+ FRAMERD_EXPORT fd_lisp fd_get_oid_value(fd_lisp oref);
+
+ #if (FD_USING_THREADS)
++extern struct FD_HASHTABLE _fd_oid_buckets[FD_OID_BUCKETS];
+ FASTOP fd_lisp fd_oid_value(fd_lisp) UNUSED;
+ FASTOP fd_lisp fd_oid_value(fd_lisp obj)
+ {
+diff -Naur framerd-2.4.3-orig/include/framerd/oids.h framerd-2.4.3/include/framerd/oids.h
+--- framerd-2.4.3-orig/include/framerd/oids.h 2002-08-09 10:42:35.000000000 -0600
++++ framerd-2.4.3/include/framerd/oids.h 2007-02-19 02:05:54.000000000 -0600
+@@ -146,7 +146,6 @@
+ #define FD_MAKE_OID fd_make_oid
+ #endif /* not FD_INLINE_OIDS */
+
+-DTYPES_EXPORT struct FD_HASHTABLE _fd_oid_buckets[FD_OID_BUCKETS];
+
+ /* Note that we don't have to do OID locking when saving values here because,
+ the hashtables do it for us. */
diff --git a/dev-db/framerd/files/framerd-2.4.3-setup.fdx.patch b/dev-db/framerd/files/framerd-2.4.3-setup.fdx.patch
new file mode 100644
index 000000000000..bdc278c9d956
--- /dev/null
+++ b/dev-db/framerd/files/framerd-2.4.3-setup.fdx.patch
@@ -0,0 +1,14 @@
+diff -Naur framerd-2.4.3-orig/etc/setup.fdx framerd-2.4.3/etc/setup.fdx
+--- framerd-2.4.3-orig/etc/setup.fdx 2002-08-13 06:48:59.000000000 -0600
++++ framerd-2.4.3/etc/setup.fdx 2007-02-19 02:15:31.000000000 -0600
+@@ -124,8 +124,8 @@
+ (unless win32p
+ (system "chmod go-w " (destdir config-file)))
+ (lineout ">>> Wrote out FramerD configuration into " (destdir config-file))
+-(unless (file-exists? (destdir (stringout framerd-lib "/servers")))
+- (call-with-output-file (destdir (stringout framerd-lib "/servers"))
++(unless (file-exists? (stringout framerd-lib "/servers"))
++ (call-with-output-file (stringout framerd-lib "/servers")
+ (lambda (port) #f)))
+
+
diff --git a/dev-db/framerd/files/setup.fdx.patch b/dev-db/framerd/files/setup.fdx.patch
deleted file mode 100644
index 910722144882..000000000000
--- a/dev-db/framerd/files/setup.fdx.patch
+++ /dev/null
@@ -1,6 +0,0 @@
-127,128c127,128
-< (unless (file-exists? (destdir (stringout framerd-lib "/servers")))
-< (call-with-output-file (destdir (stringout framerd-lib "/servers"))
----
-> (unless (file-exists? (stringout framerd-lib "/servers"))
-> (call-with-output-file (stringout framerd-lib "/servers")
diff --git a/dev-db/framerd/framerd-2.4.3-r1.ebuild b/dev-db/framerd/framerd-2.4.3-r1.ebuild
index bc72bf8c606c..2535c23a0534 100644
--- a/dev-db/framerd/framerd-2.4.3-r1.ebuild
+++ b/dev-db/framerd/framerd-2.4.3-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/framerd/framerd-2.4.3-r1.ebuild,v 1.14 2006/04/01 14:29:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/framerd/framerd-2.4.3-r1.ebuild,v 1.15 2007/02/19 08:27:18 dirtyepic Exp $
+
+inherit eutils
DESCRIPTION="FramerD is a portable distributed object-oriented database designed to support the maintenance and sharing of knowledge bases."
HOMEPAGE="http://www.framerd.org/"
@@ -11,19 +13,23 @@ SLOT="0"
KEYWORDS="~ia64 x86"
IUSE="readline"
-DEPEND="virtual/libc
- readline? ( >=sys-libs/readline-4.1-r4 )"
+DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-setup.fdx.patch
+}
src_compile() {
- patch -p0 ${S}/etc/setup.fdx ${FILESDIR}/setup.fdx.patch
- MY_OPTS="--enable-shared"
- if ! use readline; then
- MY_OPTS="${MY_OPTS} --without-readline"
- fi
- econf ${MY_OPTS} || die "econf failed"
+ econf \
+ $(use_with readline) \
+ --enable-shared \
+ || die "econf failed"
emake || die "make failed"
- #emake test || die "make test failed" # failed!!
}
src_install() {