summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2014-05-22 21:03:28 +0000
committerChristian Ruppert <idl0r@gentoo.org>2014-05-22 21:03:28 +0000
commit0f5b69836819f4a5bc37d620c4bc8e59db1bb40e (patch)
tree9d714380214da1a87e19e98409105830cbf9a780 /dev-db/xtrabackup-bin
parentAdd myself as secondary maintainer (diff)
downloadgentoo-2-0f5b69836819f4a5bc37d620c4bc8e59db1bb40e.tar.gz
gentoo-2-0f5b69836819f4a5bc37d620c4bc8e59db1bb40e.tar.bz2
gentoo-2-0f5b69836819f4a5bc37d620c4bc8e59db1bb40e.zip
Version bump, bug 510554. Also fixes runtime dependencies, bug 510756. Thanks to Thomas D. <whissi@whissi.de>
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'dev-db/xtrabackup-bin')
-rw-r--r--dev-db/xtrabackup-bin/ChangeLog9
-rw-r--r--dev-db/xtrabackup-bin/xtrabackup-bin-2.1.9.ebuild56
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-db/xtrabackup-bin/ChangeLog b/dev-db/xtrabackup-bin/ChangeLog
index c5158162331a..9dca4badf921 100644
--- a/dev-db/xtrabackup-bin/ChangeLog
+++ b/dev-db/xtrabackup-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/xtrabackup-bin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xtrabackup-bin/ChangeLog,v 1.6 2014/03/01 22:27:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xtrabackup-bin/ChangeLog,v 1.7 2014/05/22 21:03:28 idl0r Exp $
+
+*xtrabackup-bin-2.1.9 (22 May 2014)
+
+ 22 May 2014; Christian Ruppert <idl0r@gentoo.org>
+ +xtrabackup-bin-2.1.9.ebuild:
+ Version bump, bug 510554. Also fixes runtime dependencies, bug 510756. Thanks
+ to Thomas D. <whissi@whissi.de>
01 Mar 2014; Michał Górny <mgorny@gentoo.org> xtrabackup-bin-2.1.7.ebuild:
Update libgcrypt dep to use slot :0.
diff --git a/dev-db/xtrabackup-bin/xtrabackup-bin-2.1.9.ebuild b/dev-db/xtrabackup-bin/xtrabackup-bin-2.1.9.ebuild
new file mode 100644
index 000000000000..3f7197c6bc05
--- /dev/null
+++ b/dev-db/xtrabackup-bin/xtrabackup-bin-2.1.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xtrabackup-bin/xtrabackup-bin-2.1.9.ebuild,v 1.1 2014/05/22 21:03:28 idl0r Exp $
+
+EAPI=5
+
+MY_PN="percona-${PN/-bin}"
+MY_PVR="${PV}-744"
+MY_P="${MY_PN}-${PV}"
+MY_PF="${MY_PN}-${MY_PVR}"
+
+inherit eutils
+
+DESCRIPTION="MySQL hot backup software that performs non-blocking backups for
+InnoDB and XtraDB databases"
+HOMEPAGE="http://www.percona.com/software/percona-xtrabackup"
+SRC_URI="
+ amd64? (
+ http://www.percona.com/downloads/XtraBackup/XtraBackup-${PV}/binary/Linux/x86_64/${MY_PF}-Linux-x86_64.tar.gz -> ${MY_P}-x86_64.tar.gz
+ )
+ x86? (
+ http://www.percona.com/downloads/XtraBackup/XtraBackup-${PV}/binary/Linux/i686/${MY_PF}-Linux-i686.tar.gz -> ${MY_P}-x86_32.tar.gz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-libs/libaio
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ dev-perl/DBD-mysql"
+
+if use amd64; then
+ S="${WORKDIR}/${MY_P}-Linux-x86_64"
+elif use x86; then
+ S="${WORKDIR}/${MY_P}-Linux-i686"
+fi
+
+src_prepare() {
+ # bug 501904 - CVE-2014-2029
+ epatch "${FILESDIR}/${PN}-2.1.7-no-versioncheck.patch"
+}
+
+src_install() {
+ for bin in innobackupex xbcrypt xbstream xtrabackup xtrabackup_55 xtrabackup_56; do
+ dobin bin/${bin}
+ done
+ dosym /usr/bin/innobackupex /usr/bin/innobackupex-1.5.1
+}
+
+pkg_postinst() {
+ einfo "xtrabackup 2.1.x is for MySQL/MariaDB 5.5 and 5.6 only"
+}