summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-22 15:00:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-22 15:00:11 +0000
commitcc62f0520214e4df3a59c8480c98a44c161f77e5 (patch)
treeb6918f6926ad1b41e5f9072fbd7b088e040fc086 /dev-db/unixODBC
parentVersion bump (diff)
downloadgentoo-2-cc62f0520214e4df3a59c8480c98a44c161f77e5.tar.gz
gentoo-2-cc62f0520214e4df3a59c8480c98a44c161f77e5.tar.bz2
gentoo-2-cc62f0520214e4df3a59c8480c98a44c161f77e5.zip
Version bump wrt #249617, thanks to Tais P. Hansen, Bjoern Thorwirth and others.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/ChangeLog9
-rw-r--r--dev-db/unixODBC/files/odbcinst.ini22
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.14.ebuild68
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index 9fd904bf7fb3..f779d9b5e402 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/unixODBC
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.76 2010/03/22 08:35:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.77 2010/03/22 15:00:10 ssuominen Exp $
+
+*unixODBC-2.2.14 (22 Mar 2010)
+
+ 22 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +unixODBC-2.2.14.ebuild, +files/odbcinst.ini:
+ Version bump wrt #249617, thanks to Tais P. Hansen, Bjoern Thorwirth and
+ others.
22 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
unixODBC-2.2.12.ebuild:
diff --git a/dev-db/unixODBC/files/odbcinst.ini b/dev-db/unixODBC/files/odbcinst.ini
new file mode 100644
index 000000000000..29ea10aa5773
--- /dev/null
+++ b/dev-db/unixODBC/files/odbcinst.ini
@@ -0,0 +1,22 @@
+# Example driver definitions
+
+# Driver from the postgresql-odbc package
+# Setup from the unixODBC package
+[PostgreSQL]
+Description = ODBC for PostgreSQL
+Driver = /usr/lib/psqlodbc.so
+Setup = /usr/lib/libodbcpsqlS.so
+Driver64 = /usr/lib64/psqlodbc.so
+Setup64 = /usr/lib64/libodbcpsqlS.so
+FileUsage = 1
+
+
+# Driver from the mysql-connector-odbc package
+# Setup from the unixODBC package
+[MySQL]
+Description = ODBC for MySQL
+Driver = /usr/lib/libmyodbc5.so
+Setup = /usr/lib/libodbcmyS.so
+Driver64 = /usr/lib64/libmyodbc5.so
+Setup64 = /usr/lib64/libodbcmyS.so
+FileUsage = 1
diff --git a/dev-db/unixODBC/unixODBC-2.2.14.ebuild b/dev-db/unixODBC/unixODBC-2.2.14.ebuild
new file mode 100644
index 000000000000..909650ee4bce
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.2.14.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.14.ebuild,v 1.1 2010/03/22 15:00:10 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="mirror://sourceforge/unixodbc/${P}.tar.gz
+ http://dev.gentoo.org/~ssuominen/${P}-patchset-1.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs qt4"
+
+RDEPEND=">=sys-libs/readline-6.0
+ >=sys-libs/ncurses-5.6
+ sys-devel/libtool
+ qt4? ( x11-libs/qt-assistant:4
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patches
+
+ # clean up old moc files and bundled libtool
+ rm -rf libltdl odbcinstQ4/m*.cpp
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="--enable-gui=no"
+
+ use qt4 && myconf="--enable-gui=yes"
+
+ # 2.2.14 is not aliasing-safe
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --sysconfdir=/etc/${PN} \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ --enable-fdb \
+ --enable-ltdllib \
+ --with-qt-libraries=/usr/$(get_libdir)/qt4 \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README*
+ dohtml -a gif,html,sql -r doc/*
+
+ # http://cvs.fedoraproject.org/viewvc/rpms/unixODBC/devel/
+ insinto /etc/unixODBC
+ newins "${FILESDIR}"/odbcinst.ini odbcinst.ini.example
+
+ if use qt4; then
+ newicon DataManager/LinuxODBC.xpm ${PN}.xpm
+ make_desktop_entry ODBCConfig "ODBC Data Source Administrator"
+ fi
+}