summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-11-08 19:34:31 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-11-08 19:34:31 +0000
commit53b0ef33ee8a2cbd833db3b98192b8a296644242 (patch)
tree176d4d64b28bffc0f415308d8bd907050c8eae42 /dev-db/pygresql/pygresql-3.8.1.ebuild
parentSimplified logic a bit. Updated firmware-file-names, added new files. (diff)
downloadgentoo-2-53b0ef33ee8a2cbd833db3b98192b8a296644242.tar.gz
gentoo-2-53b0ef33ee8a2cbd833db3b98192b8a296644242.tar.bz2
gentoo-2-53b0ef33ee8a2cbd833db3b98192b8a296644242.zip
Version bump. Dependency and ebuild cleanups: bug 149320, thanks to Frederik Holljen.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'dev-db/pygresql/pygresql-3.8.1.ebuild')
-rw-r--r--dev-db/pygresql/pygresql-3.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/pygresql/pygresql-3.8.1.ebuild b/dev-db/pygresql/pygresql-3.8.1.ebuild
new file mode 100644
index 000000000000..a7114d4f1930
--- /dev/null
+++ b/dev-db/pygresql/pygresql-3.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.8.1.ebuild,v 1.1 2006/11/08 19:34:31 dev-zero Exp $
+
+inherit eutils distutils
+
+KEYWORDS="~sparc ~x86"
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+HOMEPAGE="http://www.pygresql.org/"
+LICENSE="as-is"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-db/libpq"
+RDEPEND="${DEPEND}
+ dev-python/egenix-mx-base"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ dodoc docs/*.txt
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/*
+ dohtml docs/*.{html,css}
+ fi
+}