summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-25 08:26:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-25 08:26:54 +0000
commitcf93df82feff3b2a69efd5c84af99270a9a85052 (patch)
tree5346d93ac0e20a5ef614880c363ed67b768d8a47 /dev-db/postgresql-docs
parentBump (diff)
downloadgentoo-2-cf93df82feff3b2a69efd5c84af99270a9a85052.tar.gz
gentoo-2-cf93df82feff3b2a69efd5c84af99270a9a85052.tar.bz2
gentoo-2-cf93df82feff3b2a69efd5c84af99270a9a85052.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/postgresql-docs')
-rw-r--r--dev-db/postgresql-docs/ChangeLog15
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.4.22.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.0.18.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.1.14.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.2.9.ebuild59
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.3.5.ebuild59
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.4_beta2.ebuild59
7 files changed, 344 insertions, 1 deletions
diff --git a/dev-db/postgresql-docs/ChangeLog b/dev-db/postgresql-docs/ChangeLog
index 0058768547a4..5afd15344305 100644
--- a/dev-db/postgresql-docs/ChangeLog
+++ b/dev-db/postgresql-docs/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-db/postgresql-docs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.237 2014/06/26 07:19:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.238 2014/07/25 08:26:54 patrick Exp $
+
+*postgresql-docs-9.1.14 (25 Jul 2014)
+*postgresql-docs-9.3.5 (25 Jul 2014)
+*postgresql-docs-9.0.18 (25 Jul 2014)
+*postgresql-docs-9.4_beta2 (25 Jul 2014)
+*postgresql-docs-9.2.9 (25 Jul 2014)
+*postgresql-docs-8.4.22 (25 Jul 2014)
+
+ 25 Jul 2014; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-docs-8.4.22.ebuild, +postgresql-docs-9.0.18.ebuild,
+ +postgresql-docs-9.1.14.ebuild, +postgresql-docs-9.2.9.ebuild,
+ +postgresql-docs-9.3.5.ebuild, +postgresql-docs-9.4_beta2.ebuild:
+ Bump
*postgresql-docs-9.4_beta1 (26 Jun 2014)
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.4.22.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.4.22.ebuild
new file mode 100644
index 000000000000..d73a84e995de
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-8.4.22.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.4.22.ebuild,v 1.1 2014/07/25 08:26:54 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ dodir ${mypath}/html
+ tar -zxf "postgres.tar.gz" -C "${ED}${mypath}/html" || die
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.0.18.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.0.18.ebuild
new file mode 100644
index 000000000000..48abc3a7e9ad
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.0.18.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.0.18.ebuild,v 1.1 2014/07/25 08:26:54 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.1.14.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.1.14.ebuild
new file mode 100644
index 000000000000..5cd4761a46ec
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.1.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.1.14.ebuild,v 1.1 2014/07/25 08:26:54 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+SLOT="$(get_version_component_range 1-2)"
+S="${WORKDIR}/postgresql-${PV}"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.2.9.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.2.9.ebuild
new file mode 100644
index 000000000000..62f9e71e7160
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.2.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.2.9.ebuild,v 1.1 2014/07/25 08:26:54 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+#MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+#S="${WORKDIR}/postgresql-${MY_FILE_PV}"
+#SRC_URI="mirror://postgresql/source/v${MY_FILE_PV}/postgresql-${MY_FILE_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+S="${WORKDIR}/postgresql-${PV}"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.3.5.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.3.5.ebuild
new file mode 100644
index 000000000000..2e065243b053
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.3.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.3.5.ebuild,v 1.1 2014/07/25 08:26:54 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+#MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+#S="${WORKDIR}/postgresql-${MY_FILE_PV}"
+#SRC_URI="mirror://postgresql/source/v${MY_FILE_PV}/postgresql-${MY_FILE_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+S="${WORKDIR}/postgresql-${PV}"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.4_beta2.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.4_beta2.ebuild
new file mode 100644
index 000000000000..b7e230ade9ac
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.4_beta2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.4_beta2.ebuild,v 1.1 2014/07/25 08:26:54 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+S="${WORKDIR}/postgresql-${MY_PV}"
+SRC_URI="mirror://postgresql/source/v${MY_PV}/postgresql-${MY_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+#S="${WORKDIR}/postgresql-${PV}"
+#SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}