summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-04-23 15:00:45 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-04-23 15:00:45 +0000
commita1e42bb4b674b837f9a20156559388c178e6e532 (patch)
treee0b95962fd3aa9494862b7959637957f62a1aef0 /dev-db/pgpool2
parentremove old (diff)
downloadgentoo-2-a1e42bb4b674b837f9a20156559388c178e6e532.tar.gz
gentoo-2-a1e42bb4b674b837f9a20156559388c178e6e532.tar.bz2
gentoo-2-a1e42bb4b674b837f9a20156559388c178e6e532.zip
Version bump. Fixes bug 410059. Fixed minor syntax.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/pgpool2')
-rw-r--r--dev-db/pgpool2/ChangeLog11
-rw-r--r--dev-db/pgpool2/pgpool2-3.0.4.ebuild6
-rw-r--r--dev-db/pgpool2/pgpool2-3.0.7.ebuild77
-rw-r--r--dev-db/pgpool2/pgpool2-3.1.3.ebuild77
-rw-r--r--dev-db/pgpool2/pgpool2-9999.ebuild6
5 files changed, 169 insertions, 8 deletions
diff --git a/dev-db/pgpool2/ChangeLog b/dev-db/pgpool2/ChangeLog
index 9a6401b34797..9b97ed5aab0c 100644
--- a/dev-db/pgpool2/ChangeLog
+++ b/dev-db/pgpool2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/pgpool2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/ChangeLog,v 1.8 2011/06/19 18:50:43 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/ChangeLog,v 1.9 2012/04/23 15:00:44 titanofold Exp $
+
+*pgpool2-3.1.3 (23 Apr 2012)
+*pgpool2-3.0.7 (23 Apr 2012)
+
+ 23 Apr 2012; Aaron W. Swenson <titanofold@gentoo.org> pgpool2-3.0.4.ebuild,
+ +pgpool2-3.0.7.ebuild, +pgpool2-3.1.3.ebuild, pgpool2-9999.ebuild:
+ Version bump. Fixes bug 410059. Fixed minor syntax.
*pgpool2-3.0.4 (19 Jun 2011)
diff --git a/dev-db/pgpool2/pgpool2-3.0.4.ebuild b/dev-db/pgpool2/pgpool2-3.0.4.ebuild
index e177bbebc1b6..9f216ea0da7a 100644
--- a/dev-db/pgpool2/pgpool2-3.0.4.ebuild
+++ b/dev-db/pgpool2/pgpool2-3.0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/pgpool2-3.0.4.ebuild,v 1.1 2011/06/19 18:50:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/pgpool2-3.0.4.ebuild,v 1.2 2012/04/23 15:00:44 titanofold Exp $
EAPI=4
@@ -58,7 +58,7 @@ src_prepare() {
src_configure() {
econf \
- --sysconfdir=${EROOT}/etc/${PN} \
+ --sysconfdir="${EROOT}/etc/${PN}" \
--disable-rpath \
$(use_enable static-libs static) \
$(use_with ssl openssl) \
diff --git a/dev-db/pgpool2/pgpool2-3.0.7.ebuild b/dev-db/pgpool2/pgpool2-3.0.7.ebuild
new file mode 100644
index 000000000000..43b7108c1bdc
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-3.0.7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/pgpool2-3.0.7.ebuild,v 1.1 2012/04/23 15:00:45 titanofold Exp $
+
+EAPI=4
+
+[[ ${PV} == 9999 ]] && MY_P=${PN/2/-II} || MY_P="${PN/2/-II}-${PV}"
+
+ECVS_SERVER="cvs.pgfoundry.org:/cvsroot/pgpool"
+ECVS_MODULE="pgpool-II"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="cvs"
+inherit base autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="http://pgpool.projects.postgresql.org/"
+[[ ${PV} == 9999 ]] || SRC_URI="http://pgfoundry.org/frs/download.php/3076/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86"
+IUSE="pam ssl static-libs"
+
+RDEPEND="
+ dev-db/postgresql-base
+ pam? ( sys-auth/pambase )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${DEPEND}
+ sys-devel/bison
+ !!dev-db/pgpool
+"
+
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+DOCS=(
+ "NEWS"
+ "doc/where_to_send_queries.pdf"
+)
+HTML_DOCS=(
+ "doc/pgpool-en.html"
+ "doc/pgpool.css"
+ "doc/tutorial-en.html"
+)
+
+# Those turkeys didn't update the directory name!'
+#S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/pgpool-II-3.0.4"
+
+src_prepare() {
+ sed -i \
+ -e 's:/tmp/:/var/run/postgresql:g' \
+ pgpool.conf.sample pool.h || die
+ sed -i \
+ -e '/ACLOCAL_AMFLAGS/ d' \
+ Makefile.am || die
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EROOT}/etc/${PN}" \
+ --disable-rpath \
+ $(use_enable static-libs static) \
+ $(use_with ssl openssl) \
+ $(use_with pam)
+}
+
+src_install() {
+ base_src_install
+ find "${ED}" -name '*.la' -exec rm -f {} +
+ # move misc data to proper folder
+ mv "${ED}/usr/share/${PN/2/-II}" "${ED}/usr/share/${PN}" || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
diff --git a/dev-db/pgpool2/pgpool2-3.1.3.ebuild b/dev-db/pgpool2/pgpool2-3.1.3.ebuild
new file mode 100644
index 000000000000..c3405a15379b
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-3.1.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/pgpool2-3.1.3.ebuild,v 1.1 2012/04/23 15:00:45 titanofold Exp $
+
+EAPI=4
+
+[[ ${PV} == 9999 ]] && MY_P=${PN/2/-II} || MY_P="${PN/2/-II}-${PV}"
+
+ECVS_SERVER="cvs.pgfoundry.org:/cvsroot/pgpool"
+ECVS_MODULE="pgpool-II"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="cvs"
+inherit base autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="http://pgpool.projects.postgresql.org/"
+[[ ${PV} == 9999 ]] || SRC_URI="http://pgfoundry.org/frs/download.php/3076/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86"
+IUSE="pam ssl static-libs"
+
+RDEPEND="
+ dev-db/postgresql-base
+ pam? ( sys-auth/pambase )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${DEPEND}
+ sys-devel/bison
+ !!dev-db/pgpool
+"
+
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+DOCS=(
+ "NEWS"
+ "doc/where_to_send_queries.pdf"
+)
+HTML_DOCS=(
+ "doc/pgpool-en.html"
+ "doc/pgpool.css"
+ "doc/tutorial-en.html"
+)
+
+# Those turkeys didn't update the directory name!'
+#S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/pgpool-II-3.0.4"
+
+src_prepare() {
+ sed -i \
+ -e 's:/tmp/:/var/run/postgresql:g' \
+ pgpool.conf.sample pool.h || die
+ sed -i \
+ -e '/ACLOCAL_AMFLAGS/ d' \
+ Makefile.am || die
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EROOT}/etc/${PN}" \
+ --disable-rpath \
+ $(use_enable static-libs static) \
+ $(use_with ssl openssl) \
+ $(use_with pam)
+}
+
+src_install() {
+ base_src_install
+ find "${ED}" -name '*.la' -exec rm -f {} +
+ # move misc data to proper folder
+ mv "${ED}/usr/share/${PN/2/-II}" "${ED}/usr/share/${PN}" || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
diff --git a/dev-db/pgpool2/pgpool2-9999.ebuild b/dev-db/pgpool2/pgpool2-9999.ebuild
index c1d066d7f1fc..ce717286d285 100644
--- a/dev-db/pgpool2/pgpool2-9999.ebuild
+++ b/dev-db/pgpool2/pgpool2-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/pgpool2-9999.ebuild,v 1.3 2011/06/19 18:50:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/pgpool2-9999.ebuild,v 1.4 2012/04/23 15:00:45 titanofold Exp $
EAPI=4
@@ -58,7 +58,7 @@ src_prepare() {
src_configure() {
econf \
- --sysconfdir=${EROOT}/etc/${PN} \
+ --sysconfdir="${EROOT}/etc/${PN}" \
--disable-rpath \
$(use_enable static-libs static) \
$(use_with ssl openssl) \