summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2014-03-10 21:15:06 +0000
committerSven Wegener <swegener@gentoo.org>2014-03-10 21:15:06 +0000
commit87d284e95b0c6936fd066ce4bc277124793371f9 (patch)
treefbf5f8aa9f429d651c075854b5a8409471053ea3 /dev-db/opendbx
parent~x86 added, bug #491036 (diff)
downloadgentoo-2-87d284e95b0c6936fd066ce4bc277124793371f9.tar.gz
gentoo-2-87d284e95b0c6936fd066ce4bc277124793371f9.tar.bz2
gentoo-2-87d284e95b0c6936fd066ce4bc277124793371f9.zip
Add local description for bindist USE flag, bug #448918. Bump EAPI for REQUIRED_USE support.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'dev-db/opendbx')
-rw-r--r--dev-db/opendbx/ChangeLog11
-rw-r--r--dev-db/opendbx/metadata.xml4
-rw-r--r--dev-db/opendbx/opendbx-1.4.5-r1.ebuild68
-rw-r--r--dev-db/opendbx/opendbx-1.4.6.ebuild12
-rw-r--r--dev-db/opendbx/opendbx-1.5.0.ebuild12
5 files changed, 95 insertions, 12 deletions
diff --git a/dev-db/opendbx/ChangeLog b/dev-db/opendbx/ChangeLog
index a8d5c591d708..ea36ae00b209 100644
--- a/dev-db/opendbx/ChangeLog
+++ b/dev-db/opendbx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/opendbx
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.36 2013/10/28 18:13:58 grobian Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.37 2014/03/10 21:15:06 swegener Exp $
+
+*opendbx-1.4.5-r1 (10 Mar 2014)
+
+ 10 Mar 2014; Sven Wegener <swegener@gentoo.org> +opendbx-1.4.5-r1.ebuild,
+ opendbx-1.4.6.ebuild, opendbx-1.5.0.ebuild, metadata.xml:
+ Add local description for bindist USE flag, bug #448918. Bump EAPI for
+ REQUIRED_USE support.
28 Oct 2013; Fabian Groffen <grobian@gentoo.org> opendbx-1.4.6.ebuild,
opendbx-1.5.0.ebuild:
diff --git a/dev-db/opendbx/metadata.xml b/dev-db/opendbx/metadata.xml
index e720ee939cb4..c4765a2b8c83 100644
--- a/dev-db/opendbx/metadata.xml
+++ b/dev-db/opendbx/metadata.xml
@@ -5,4 +5,8 @@
<email>swegener@gentoo.org</email>
<description>Primary Maintainer</description>
</maintainer>
+<use>
+ <flag name="bindist">Disable support for <pkg>dev-db/firebird</pkg> database
+ which is not GPL compatible.</flag>
+</use>
</pkgmetadata>
diff --git a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
new file mode 100644
index 000000000000..393c4d00d46e
--- /dev/null
+++ b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.5-r1.ebuild,v 1.1 2014/03/10 21:15:06 swegener Exp $
+
+EAPI="5"
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="OpenDBX - A database abstraction layer"
+HOMEPAGE="http://www.linuxnetworks.de/doc/index.php/OpenDBX"
+SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bindist firebird +mysql oracle postgres sqlite sqlite3"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( <dev-db/sqlite-3 )
+ sqlite3? ( =dev-db/sqlite-3* )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ firebird? ( dev-db/firebird )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="bindist? ( !firebird )"
+
+pkg_setup() {
+ if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
+ then
+ ewarn "You should enable at least one of the following USE flags:"
+ ewarn "firebird, mysql, oracle, postgres, sqlite or sqlite3"
+ fi
+
+ if use oracle && [[ ! -d ${ORACLE_HOME} ]]
+ then
+ die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
+ fi
+
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+}
+
+src_configure() {
+ local backends=""
+
+ use !bindist && use firebird && backends="${backends} firebird"
+ use mysql && backends="${backends} mysql"
+ use oracle && backends="${backends} oracle"
+ use postgres && backends="${backends} pgsql"
+ use sqlite && backends="${backends} sqlite"
+ use sqlite3 && backends="${backends} sqlite3"
+
+ econf --with-backends="${backends}" || die "econf failed"
+}
+
+src_compile() {
+ # bug #322221
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+
+ rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
+}
diff --git a/dev-db/opendbx/opendbx-1.4.6.ebuild b/dev-db/opendbx/opendbx-1.4.6.ebuild
index b1b4fd1a869a..df2764086327 100644
--- a/dev-db/opendbx/opendbx-1.4.6.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.6.ebuild,v 1.2 2013/10/28 18:13:58 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.6.ebuild,v 1.3 2014/03/10 21:15:06 swegener Exp $
-EAPI="2"
+EAPI="5"
inherit flag-o-matic multilib
@@ -20,11 +20,13 @@ DEPEND="mysql? ( virtual/mysql )
sqlite? ( <dev-db/sqlite-3 )
sqlite3? ( =dev-db/sqlite-3* )
oracle? ( dev-db/oracle-instantclient-basic )
- !bindist? ( firebird? ( dev-db/firebird ) )"
+ firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
+REQUIRED_USE="bindist? ( !firebird )"
+
pkg_setup() {
- if ! ( use !bindist && use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
+ if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
then
ewarn "You should enable at least one of the following USE flags:"
ewarn "firebird, mysql, oracle, postgres, sqlite or sqlite3"
diff --git a/dev-db/opendbx/opendbx-1.5.0.ebuild b/dev-db/opendbx/opendbx-1.5.0.ebuild
index 5879dbca59c6..1abb3c10b0a9 100644
--- a/dev-db/opendbx/opendbx-1.5.0.ebuild
+++ b/dev-db/opendbx/opendbx-1.5.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.5.0.ebuild,v 1.2 2013/10/28 18:13:58 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.5.0.ebuild,v 1.3 2014/03/10 21:15:06 swegener Exp $
-EAPI="2"
+EAPI="5"
inherit flag-o-matic multilib
@@ -23,13 +23,15 @@ DEPEND="mysql? ( virtual/mysql )
sqlite? ( <dev-db/sqlite-3 )
sqlite3? ( =dev-db/sqlite-3* )
oracle? ( dev-db/oracle-instantclient-basic )
- !bindist? ( firebird? ( dev-db/firebird ) )"
+ firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
+REQUIRED_USE="bindist? ( !firebird )"
+
S="${WORKDIR}"/${MY_P}
pkg_setup() {
- if ! ( use !bindist && use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
+ if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
then
ewarn "You should enable at least one of the following USE flags:"
ewarn "firebird, mysql, oracle, postgres, sqlite or sqlite3"