summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-07 18:28:03 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-07 18:28:03 +0000
commit8449bcc784bdf8dbcaf4fd41b47823a53c731982 (patch)
tree60e62b2ab292ceaeef24780ef9fb7161092ffe12 /dev-db/opendbx
parentAvoid sys-auth/polkit-kde-agent blockers with Plasma 5. (diff)
downloadgentoo-2-8449bcc784bdf8dbcaf4fd41b47823a53c731982.tar.gz
gentoo-2-8449bcc784bdf8dbcaf4fd41b47823a53c731982.tar.bz2
gentoo-2-8449bcc784bdf8dbcaf4fd41b47823a53c731982.zip
Drop sqlite2 support and rename sqlite3 USE to sqlite (#530176)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-db/opendbx')
-rw-r--r--dev-db/opendbx/ChangeLog10
-rw-r--r--dev-db/opendbx/opendbx-1.4.5-r1.ebuild65
-rw-r--r--dev-db/opendbx/opendbx-1.4.6-r1.ebuild65
-rw-r--r--dev-db/opendbx/opendbx-1.5.0-r1.ebuild70
4 files changed, 209 insertions, 1 deletions
diff --git a/dev-db/opendbx/ChangeLog b/dev-db/opendbx/ChangeLog
index 4ee743a30d10..e0d637a9abbd 100644
--- a/dev-db/opendbx/ChangeLog
+++ b/dev-db/opendbx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/opendbx
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.43 2015/03/15 18:03:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.44 2015/05/07 18:28:03 pacho Exp $
+
+*opendbx-1.4.5-r1 (07 May 2015)
+*opendbx-1.5.0-r1 (07 May 2015)
+*opendbx-1.4.6-r1 (07 May 2015)
+
+ 07 May 2015; Pacho Ramos <pacho@gentoo.org> +opendbx-1.4.5-r1.ebuild,
+ +opendbx-1.4.6-r1.ebuild, +opendbx-1.5.0-r1.ebuild:
+ Drop sqlite2 support and rename sqlite3 USE to sqlite (#530176)
15 Mar 2015; Ulrich Müller <ulm@gentoo.org> opendbx-1.4.5.ebuild,
opendbx-1.4.6.ebuild, opendbx-1.5.0.ebuild, metadata.xml:
diff --git a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
new file mode 100644
index 000000000000..d5adda4a35b6
--- /dev/null
+++ b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.5-r1.ebuild,v 1.3 2015/05/07 18:28:03 pacho Exp $
+
+EAPI="5"
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="OpenDBX - A database abstraction layer"
+HOMEPAGE="http://www.linuxnetworks.de/doc/index.php/OpenDBX"
+SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="firebird +mysql oracle postgres sqlite"
+RESTRICT="firebird? ( bindist )"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( dev-db/sqlite:3 )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ firebird? ( dev-db/firebird )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
+ then
+ ewarn "You should enable at least one of the following USE flags:"
+ ewarn "firebird, mysql, oracle, postgres or sqlite"
+ fi
+
+ if use oracle && [[ ! -d ${ORACLE_HOME} ]]
+ then
+ die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
+ fi
+
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+}
+
+src_configure() {
+ local backends=""
+
+ use firebird && backends="${backends} firebird"
+ use mysql && backends="${backends} mysql"
+ use oracle && backends="${backends} oracle"
+ use postgres && backends="${backends} pgsql"
+ use sqlite && backends="${backends} sqlite3"
+
+ econf --with-backends="${backends}"
+}
+
+src_compile() {
+ # bug #322221
+ emake -j1
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog README
+
+ rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
+}
diff --git a/dev-db/opendbx/opendbx-1.4.6-r1.ebuild b/dev-db/opendbx/opendbx-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..38f2b6afd088
--- /dev/null
+++ b/dev-db/opendbx/opendbx-1.4.6-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.6-r1.ebuild,v 1.1 2015/05/07 18:28:03 pacho Exp $
+
+EAPI="5"
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="OpenDBX - A database abstraction layer"
+HOMEPAGE="http://www.linuxnetworks.de/doc/index.php/OpenDBX"
+SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="firebird +mysql oracle postgres sqlite"
+RESTRICT="firebird? ( bindist )"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( dev-db/sqlite:3 )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ firebird? ( dev-db/firebird )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
+ then
+ ewarn "You should enable at least one of the following USE flags:"
+ ewarn "firebird, mysql, oracle, postgres or sqlite"
+ fi
+
+ if use oracle && [[ ! -d ${ORACLE_HOME} ]]
+ then
+ die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
+ fi
+
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+}
+
+src_configure() {
+ local backends=""
+
+ use firebird && backends="${backends} firebird"
+ use mysql && backends="${backends} mysql"
+ use oracle && backends="${backends} oracle"
+ use postgres && backends="${backends} pgsql"
+ use sqlite && backends="${backends} sqlite3"
+
+ econf --with-backends="${backends}" || die "econf failed"
+}
+
+src_compile() {
+ # bug #322221
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+
+ rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
+}
diff --git a/dev-db/opendbx/opendbx-1.5.0-r1.ebuild b/dev-db/opendbx/opendbx-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..21be99e93e7a
--- /dev/null
+++ b/dev-db/opendbx/opendbx-1.5.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.5.0-r1.ebuild,v 1.1 2015/05/07 18:28:03 pacho Exp $
+
+EAPI="5"
+
+inherit flag-o-matic multilib
+
+MY_PN="lib${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="OpenDBX - A database abstraction layer"
+HOMEPAGE="http://www.linuxnetworks.de/doc/index.php/OpenDBX"
+SRC_URI="http://www.linuxnetworks.de/opendbx/download/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x64-solaris"
+IUSE="firebird +mysql oracle postgres sqlite"
+RESTRICT="firebird? ( bindist )"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( dev-db/sqlite:3 )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ firebird? ( dev-db/firebird )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
+ then
+ ewarn "You should enable at least one of the following USE flags:"
+ ewarn "firebird, mysql, oracle, postgres or sqlite"
+ fi
+
+ if use oracle && [[ ! -d ${ORACLE_HOME} ]]
+ then
+ die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
+ fi
+
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+}
+
+src_configure() {
+ local backends=""
+
+ use firebird && backends="${backends} firebird"
+ use mysql && backends="${backends} mysql"
+ use oracle && backends="${backends} oracle"
+ use postgres && backends="${backends} pgsql"
+ use sqlite && backends="${backends} sqlite3"
+
+ econf --with-backends="${backends}" || die "econf failed"
+}
+
+src_compile() {
+ # bug #322221
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+
+ rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
+}