summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-12 21:57:31 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-12 21:57:31 +0000
commit9d82faed864fc00f780b531b408110f726e4c9a4 (patch)
tree5115435b7c76f9897ff8670a330380db616badd5 /dev-db/octopus
parentStable on Alpha, bug 159727. (diff)
downloadgentoo-2-9d82faed864fc00f780b531b408110f726e4c9a4.tar.gz
gentoo-2-9d82faed864fc00f780b531b408110f726e4c9a4.tar.bz2
gentoo-2-9d82faed864fc00f780b531b408110f726e4c9a4.zip
Restrict test because we would need maven to run them properly.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-db/octopus')
-rw-r--r--dev-db/octopus/ChangeLog6
-rw-r--r--dev-db/octopus/octopus-3.0.1-r1.ebuild15
2 files changed, 16 insertions, 5 deletions
diff --git a/dev-db/octopus/ChangeLog b/dev-db/octopus/ChangeLog
index f39db1d32666..adefabe83859 100644
--- a/dev-db/octopus/ChangeLog
+++ b/dev-db/octopus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/octopus
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.6 2007/02/10 23:37:23 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.7 2007/02/12 21:57:31 betelgeuse Exp $
+
+ 12 Feb 2007; Petteri Räty <betelgeuse@gentoo.org>
+ octopus-3.0.1-r1.ebuild:
+ Restrict test because we would need maven to run them properly.
10 Feb 2007; Petteri Räty <betelgeuse@gentoo.org>
octopus-3.0.1-r1.ebuild:
diff --git a/dev-db/octopus/octopus-3.0.1-r1.ebuild b/dev-db/octopus/octopus-3.0.1-r1.ebuild
index 47f95b96d031..22e36726877f 100644
--- a/dev-db/octopus/octopus-3.0.1-r1.ebuild
+++ b/dev-db/octopus/octopus-3.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1-r1.ebuild,v 1.3 2007/02/10 23:37:23 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1-r1.ebuild,v 1.4 2007/02/12 21:57:31 betelgeuse Exp $
inherit versionator java-pkg-2 java-ant-2
@@ -41,16 +41,23 @@ src_unpack() {
java-ant_rewrite-classpath build.xml
}
+EANT_GENTOO_CLASSPATH="xerces-2,rhino-1.6,ant-core,junit,log4j"
+
src_compile() {
cd ${S}/modules
use source && antflags="${antflags} sourcezip-all"
- deps="xerces-2,rhino-1.6,ant-core,junit,log4j"
- eant jar-all $(use_doc docs-all) ${antflags} \
- -Dgentoo.classpath="$(java-pkg_getjars ${deps})"
+ eant jar-all $(use_doc docs-all) ${antflags}
}
+RESTRICT="test"
+
+# Would need maven to work properly as the build.xml just launches maven
+#src_test() {
+# eant test
+#}
+
src_install() {
dodoc ChangeLog.txt ReleaseNotes.txt