summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-07-20 02:21:13 +0000
committerBrian Evans <grknight@gentoo.org>2014-07-20 02:21:13 +0000
commit613e5f8dee6dd4e1db7056226fc669d9c04dc63f (patch)
tree999b44825233df97375d06b39364fcf9cd9fd398 /dev-db/mysql++
parentRemoved compilefix patch (bug #517424) (diff)
downloadgentoo-2-613e5f8dee6dd4e1db7056226fc669d9c04dc63f.tar.gz
gentoo-2-613e5f8dee6dd4e1db7056226fc669d9c04dc63f.tar.bz2
gentoo-2-613e5f8dee6dd4e1db7056226fc669d9c04dc63f.zip
Update EAPI and fix QA warnings on old stable. This is only kept on the off chance a
user depends on this old API as nothing depends on it. No code changes or file differences (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-db/mysql++')
-rw-r--r--dev-db/mysql++/ChangeLog7
-rw-r--r--dev-db/mysql++/mysql++-2.3.2.ebuild24
2 files changed, 17 insertions, 14 deletions
diff --git a/dev-db/mysql++/ChangeLog b/dev-db/mysql++/ChangeLog
index 78626e662e32..2a15e19f2ad2 100644
--- a/dev-db/mysql++/ChangeLog
+++ b/dev-db/mysql++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql++
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.72 2014/06/07 01:54:35 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.73 2014/07/20 02:21:13 grknight Exp $
+
+ 20 Jul 2014; Brian Evans <grknight@gentoo.org> mysql++-2.3.2.ebuild:
+ Update EAPI and fix QA warnings on old stable. This is only kept on the off
+ chance a user depends on this old API as nothing depends on it. No code
+ changes or file differences
07 Jun 2014; Brian Evans <grknight@gentoo.org> -mysql++-3.0.5.ebuild,
-mysql++-3.0.9.ebuild:
diff --git a/dev-db/mysql++/mysql++-2.3.2.ebuild b/dev-db/mysql++/mysql++-2.3.2.ebuild
index 85f558c2e98d..dc65203181a8 100644
--- a/dev-db/mysql++/mysql++-2.3.2.ebuild
+++ b/dev-db/mysql++/mysql++-2.3.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.3.2.ebuild,v 1.10 2008/11/29 10:58:21 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.3.2.ebuild,v 1.11 2014/07/20 02:21:13 grknight Exp $
+
+EAPI=5
inherit eutils
@@ -17,9 +19,7 @@ RDEPEND=">=virtual/mysql-4.0"
DEPEND="${RDEPEND}
>=sys-devel/gcc-3"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc-4.3.patch
@@ -31,7 +31,7 @@ src_unpack() {
done
}
-src_compile() {
+src_configure() {
local myconf
# we want C++ exceptions turned on
myconf="--enable-exceptions"
@@ -43,16 +43,14 @@ src_compile() {
# force the cflags into place otherwise they get totally ignored by
# configure
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- econf ${myconf} || die "econf failed"
-
- emake || die "unable to make"
+ econf ${myconf}
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
# install the docs and HTML pages
dodoc README* CREDITS ChangeLog HACKERS Wishlist
- dodoc doc/*
- cp -ra doc/html "${D}"/usr/share/doc/${PF}/html
- prepalldocs
+ dohtml -r doc/html/*
+ rm -r doc/html || die
+ dodoc -r doc/*
}