summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-31 02:07:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-31 02:07:39 +0000
commit05ca6103faea1ba3218639862c87c5239a0914b0 (patch)
treeec2d5b68ab60bc56fc4058aa2ad9b4242d2b4a0f /dev-db/mydumper/mydumper-0.5.2.ebuild
parentMask flags due to firefox, thunderbird, xine not being keyworded. (diff)
downloadgentoo-2-05ca6103faea1ba3218639862c87c5239a0914b0.tar.gz
gentoo-2-05ca6103faea1ba3218639862c87c5239a0914b0.tar.bz2
gentoo-2-05ca6103faea1ba3218639862c87c5239a0914b0.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-db/mydumper/mydumper-0.5.2.ebuild')
-rw-r--r--dev-db/mydumper/mydumper-0.5.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-db/mydumper/mydumper-0.5.2.ebuild b/dev-db/mydumper/mydumper-0.5.2.ebuild
new file mode 100644
index 000000000000..4162b5f241ef
--- /dev/null
+++ b/dev-db/mydumper/mydumper-0.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mydumper/mydumper-0.5.2.ebuild,v 1.1 2012/12/31 02:07:39 flameeyes Exp $
+
+EAPI=5
+inherit cmake-utils versionator
+
+DESCRIPTION="A high-performance multi-threaded backup (and restore) toolset for MySQL and Drizzle"
+HOMEPAGE="http://www.mydumper.org/"
+SRC_URI="http://launchpad.net/mydumper/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libpcre
+ virtual/mysql
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )"
+
+DOCS=( README )
+
+src_prepare() {
+ # respect user cflags; do not expand ${CMAKE_C_FLAGS} (!)
+ sed -i -e 's:-Werror -O3 -g:${CMAKE_C_FLAGS}:' CMakeLists.txt
+ # fix doc install path
+ sed -i -e "s:share/doc/mydumper:share/doc/${PF}:" docs/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=( $(cmake-utils_use doc BUILD_DOCS) )
+
+ cmake-utils_src_configure
+}