summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-04-24 23:55:04 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-04-24 23:55:04 +0000
commit82dbff74c6e388d03ba8ca4b839147d38c827eb8 (patch)
treeca6190826c8aded6a83796dba4c0bb42da90ad59 /dev-db/mariadb
parentAutomated update. (diff)
downloadgentoo-2-82dbff74c6e388d03ba8ca4b839147d38c827eb8.tar.gz
gentoo-2-82dbff74c6e388d03ba8ca4b839147d38c827eb8.tar.bz2
gentoo-2-82dbff74c6e388d03ba8ca4b839147d38c827eb8.zip
Add mariadb-5.5.37 from the overlay - thanks to Brian Evans.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BB0E6E98)
Diffstat (limited to 'dev-db/mariadb')
-rw-r--r--dev-db/mariadb/ChangeLog10
-rw-r--r--dev-db/mariadb/files/my.cnf-5.517
-rw-r--r--dev-db/mariadb/mariadb-5.5.37.ebuild113
-rw-r--r--dev-db/mariadb/metadata.xml1
4 files changed, 129 insertions, 12 deletions
diff --git a/dev-db/mariadb/ChangeLog b/dev-db/mariadb/ChangeLog
index 43002476b94d..4c9772be2a48 100644
--- a/dev-db/mariadb/ChangeLog
+++ b/dev-db/mariadb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mariadb
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/ChangeLog,v 1.34 2013/09/04 20:38:02 jmbsvicetto Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/ChangeLog,v 1.35 2014/04/24 23:55:04 jmbsvicetto Exp $
+
+*mariadb-5.5.37 (24 Apr 2014)
+
+ 24 Apr 2014; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +mariadb-5.5.37.ebuild, files/my.cnf-5.5, metadata.xml:
+ Add mariadb-5.5.37 from the overlay - thanks to Brian Evans.
*mariadb-5.5.32 (04 Sep 2013)
diff --git a/dev-db/mariadb/files/my.cnf-5.5 b/dev-db/mariadb/files/my.cnf-5.5
index 1f425613c592..384923053336 100644
--- a/dev-db/mariadb/files/my.cnf-5.5
+++ b/dev-db/mariadb/files/my.cnf-5.5
@@ -1,5 +1,5 @@
# @GENTOO_PORTAGE_EPREFIX@/etc/mysql/my.cnf: The global mysql configuration file.
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/files/my.cnf-5.5,v 1.2 2013/01/20 02:39:55 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/files/my.cnf-5.5,v 1.3 2014/04/24 23:55:04 jmbsvicetto Exp $
# The following options will be passed to all MySQL clients
[client]
@@ -52,7 +52,7 @@ log-error = @GENTOO_PORTAGE_EPREFIX@/var/log/mysql/mysqld.err
basedir = @GENTOO_PORTAGE_EPREFIX@/usr
datadir = @DATADIR@
skip-external-locking
-key_buffer = 16M
+key_buffer_size = 16M
max_allowed_packet = 1M
table_open_cache = 64
sort_buffer_size = 512K
@@ -86,10 +86,6 @@ tmpdir = @GENTOO_PORTAGE_EPREFIX@/tmp/
#debug = d:t:i:o,/tmp/mysqld.trace
#one-thread
-# uncomment the following directives if you are using BDB tables
-#bdb_cache_size = 4M
-#bdb_max_lock = 10000
-
# the following is the InnoDB configuration
# if you wish to disable innodb instead
# uncomment just the next line
@@ -137,17 +133,18 @@ max_allowed_packet = 16M
#safe-updates
[isamchk]
-key_buffer = 20M
+key_buffer_size = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M
[myisamchk]
-key_buffer = 20M
+key_buffer_size = 20M
sort_buffer_size = 20M
-read_buffer = 2M
-write_buffer = 2M
+read_buffer_size = 2M
+write_buffer_size = 2M
[mysqlhotcopy]
interactive-timeout
+[mariadb]
diff --git a/dev-db/mariadb/mariadb-5.5.37.ebuild b/dev-db/mariadb/mariadb-5.5.37.ebuild
new file mode 100644
index 000000000000..9cf3daca8cd4
--- /dev/null
+++ b/dev-db/mariadb/mariadb-5.5.37.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/mariadb-5.5.37.ebuild,v 1.1 2014/04/24 23:55:04 jmbsvicetto Exp $
+
+EAPI="4"
+MY_EXTRAS_VER="20140424-1043Z"
+
+# Build system
+BUILD="cmake"
+
+inherit toolchain-funcs mysql-v2
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+RDEPEND="${RDEPEND}"
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='-cluster embedded extraengine perl ssl static-libs community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mariadb-X.X.XX.ebuild \
+# digest clean package
+src_test() {
+
+ local TESTDIR="${CMAKE_BUILD_DIR}/mysql-test"
+ local retstatus_unit
+ local retstatus_tests
+
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ if ! use "minimal" ; then
+
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Run CTest (test-units)
+ cmake-utils_src_test
+ retstatus_unit=$?
+ [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-tests{,/log}
+
+ # create symlink for the tests to find mysql_tzinfo_to_sql
+ ln -s "${CMAKE_BUILD_DIR}/sql/mysql_tzinfo_to_sql" "${S}/sql/"
+
+ # These are failing in MySQL 5.5 for now and are believed to be
+ # false positives:
+ #
+ # main.information_schema, binlog.binlog_statement_insert_delayed,
+ # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
+ # funcs_1.is_columns_mysql
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test, main.mysql_client_test_nonblock:
+ # segfaults at random under Portage only, suspect resource limits.
+ #
+
+ for t in main.mysql_client_test main.mysql_client_test_nonblock \
+ binlog.binlog_statement_insert_delayed main.information_schema \
+ main.mysqld--help \
+ funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
+ mysql-v2_disable_test "$t" "False positives in Gentoo"
+ done
+
+ # Run mysql tests
+ pushd "${TESTDIR}"
+
+ # run mysql-test tests
+ perl mysql-test-run.pl --force --vardir="${S}/mysql-test/var-tests"
+ retstatus_tests=$?
+ [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ popd
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+
+ failures=""
+ [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
+ [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+
+ else
+
+ einfo "Skipping server tests due to minimal build."
+ fi
+}
diff --git a/dev-db/mariadb/metadata.xml b/dev-db/mariadb/metadata.xml
index 8fb0475a57df..df3c16c9f20a 100644
--- a/dev-db/mariadb/metadata.xml
+++ b/dev-db/mariadb/metadata.xml
@@ -24,5 +24,6 @@ dev-db/mariadb
<flag name="systemtap">Build support for profiling and tracing using <pkg>dev-util/systemtap</pkg></flag>
<flag name='sphinx'>Add suport for the sphinx full-text search engine</flag>
<flag name='test'>Install upstream testsuites for end use.</flag>
+ <flag name='tokudb'>Add support for TokuDB storage engine</flag>
</use>
</pkgmetadata>