summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 16:01:17 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 16:01:17 +0000
commite537a235ea5c28d3630245b2c8d22c10e3ad10ba (patch)
treeccd865af25c2d5c77299d70b19eaa2c31e26c4c1 /dev-db/cdb
parentneed eutils for epatch (diff)
downloadgentoo-2-e537a235ea5c28d3630245b2c8d22c10e3ad10ba.tar.gz
gentoo-2-e537a235ea5c28d3630245b2c8d22c10e3ad10ba.tar.bz2
gentoo-2-e537a235ea5c28d3630245b2c8d22c10e3ad10ba.zip
need eutils for epatch
Diffstat (limited to 'dev-db/cdb')
-rw-r--r--dev-db/cdb/cdb-0.75.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/dev-db/cdb/cdb-0.75.ebuild b/dev-db/cdb/cdb-0.75.ebuild
index 8c2f3b68568f..98b2b662d9e0 100644
--- a/dev-db/cdb/cdb-0.75.ebuild
+++ b/dev-db/cdb/cdb-0.75.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.7 2003/07/31 13:51:00 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.8 2003/08/05 15:58:22 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="A fast, reliable, simple package for creating and reading constant databases"
-SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
+inherit eutils gcc
+
+DESCRIPTION="fast, reliable, simple package for creating and reading constant databases"
HOMEPAGE="http://cr.yp.to/cdb.html"
+SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86 ~alpha"
DEPEND=">=sys-apps/portage-2.0.47-r10
@@ -21,21 +22,15 @@ src_unpack() {
epatch ${FILESDIR}/${P}-errno.diff
}
-src_compile() {
- echo "gcc ${CFLAGS}" > conf-cc
- echo "gcc" > conf-ld
+src_compile() {
+ echo "$(gcc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(gcc-getCC)" > conf-ld
echo "/usr" > conf-home
emake || die "emake failed"
}
-src_install() {
- exeinto /usr/bin
- for i in cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest
- do
- doexe $i
- done
-
- into /usr
+src_install() {
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest
newlib.a cdb.a libcdb.a
insinto /usr/include
doins cdb.h