summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2006-01-18 08:00:09 +0000
committerIlya Volynets <iluxa@gentoo.org>2006-01-18 08:00:09 +0000
commit9b6da3551f97ca3e787c74f3763b846eb54b2ab5 (patch)
tree9878a98cdcf0a95499813f019c8e79a043b29420 /dev-cpp/sptk
parentFix dependencies for modular X. (diff)
downloadgentoo-2-9b6da3551f97ca3e787c74f3763b846eb54b2ab5.tar.gz
gentoo-2-9b6da3551f97ca3e787c74f3763b846eb54b2ab5.tar.bz2
gentoo-2-9b6da3551f97ca3e787c74f3763b846eb54b2ab5.zip
SPTK 3.0.12 is out
(Portage version: 2.0.53)
Diffstat (limited to 'dev-cpp/sptk')
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/Manifest2
-rw-r--r--dev-cpp/sptk/files/digest-sptk-3.0.121
-rw-r--r--dev-cpp/sptk/sptk-3.0.12.ebuild65
4 files changed, 75 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 9a241db71ae5..d983a14b7fbc 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.14 2006/01/14 12:38:43 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.15 2006/01/18 08:00:09 iluxa Exp $
+
+*sptk-3.0.12 (18 Jan 2006)
+
+ 18 Jan 2006; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.0.12.ebuild:
+ SPTK 3.0.12 is out
14 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org> sptk-3.0.6.ebuild:
Stable on x86.
diff --git a/dev-cpp/sptk/Manifest b/dev-cpp/sptk/Manifest
index 3acae3384ed7..1be21c190a07 100644
--- a/dev-cpp/sptk/Manifest
+++ b/dev-cpp/sptk/Manifest
@@ -1,8 +1,10 @@
MD5 3514718a2dcf9004bd5f7d99a12118af ChangeLog 2289
MD5 c1961e9d1e8c7ce2861b6a9f9da08038 files/digest-sptk-2.3.28 62
MD5 e9256a4a57897f70722574b5a45366fc files/digest-sptk-3.0.11 62
+MD5 2cacbf485b2a168516637950ea72492d files/digest-sptk-3.0.12 62
MD5 9d6f57f2f01a7c0acbaba21baffa4982 files/digest-sptk-3.0.6 61
MD5 fc6a5133fe3e425604dc66e248cb478c metadata.xml 327
MD5 b5cd9d1217f0d957c3926185dd0fe4b2 sptk-2.3.28.ebuild 1092
MD5 3aecb7c69a1bf39e992572bde4871665 sptk-3.0.11.ebuild 1398
+MD5 07bf6956c6839410b86eeb6e9e18e421 sptk-3.0.12.ebuild 1397
MD5 47eb44bebf1bc3ab5ee9198140ca1d5a sptk-3.0.6.ebuild 1408
diff --git a/dev-cpp/sptk/files/digest-sptk-3.0.12 b/dev-cpp/sptk/files/digest-sptk-3.0.12
new file mode 100644
index 000000000000..c76d242e9108
--- /dev/null
+++ b/dev-cpp/sptk/files/digest-sptk-3.0.12
@@ -0,0 +1 @@
+MD5 21fb6d554c8226358b93cc038d94ccf5 sptk-3.0.12.tbz2 3609302
diff --git a/dev-cpp/sptk/sptk-3.0.12.ebuild b/dev-cpp/sptk/sptk-3.0.12.ebuild
new file mode 100644
index 000000000000..098c548366fc
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.0.12.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.0.12.ebuild,v 1.1 2006/01/18 08:00:09 iluxa Exp $
+
+inherit autotools
+
+IUSE="fltk odbc doc sqlite3"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( FLTK GPL-2 )"
+KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc"
+
+DEPEND="fltk? ( x11-libs/fltk )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # This fixes double ./configure run
+ eautoreconf
+}
+
+src_compile() {
+
+ local myconf
+ myconf="--enable-shared"
+
+ econf \
+ --prefix=/usr \
+ `use_enable odbc` \
+ `use_enable fltk` \
+ `use_enable sqlite3` \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r ${S}/docs/* ${D}/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr ${D}/usr/share/doc/${PF}/latex
+ cp -r ${S}/pictures ${D}/usr/share/doc/${PF}
+ fi
+}