summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-05-03 22:40:26 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-05-03 22:40:26 +0000
commitb532d6c5d006b4faf427e54d4fff954262ff3981 (patch)
tree9759b1e06f9409ffc41263b3a41386f1b081b099 /dev-cpp/rudiments
parentInitial commit thanks to Uwe Scholz <u.scholz83@gmx.de> on bug #231885. He wi... (diff)
downloadgentoo-2-b532d6c5d006b4faf427e54d4fff954262ff3981.tar.gz
gentoo-2-b532d6c5d006b4faf427e54d4fff954262ff3981.tar.bz2
gentoo-2-b532d6c5d006b4faf427e54d4fff954262ff3981.zip
Version bump, wrt bug #488108. Update buildsystem patch - respect CFLAGS, migrate to autotools-utils eclass. Drop old versions
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-cpp/rudiments')
-rw-r--r--dev-cpp/rudiments/ChangeLog12
-rw-r--r--dev-cpp/rudiments/files/rudiments-0.46-buildsystem.patch88
-rw-r--r--dev-cpp/rudiments/rudiments-0.31.ebuild34
-rw-r--r--dev-cpp/rudiments/rudiments-0.32.ebuild34
-rw-r--r--dev-cpp/rudiments/rudiments-0.46.ebuild34
5 files changed, 132 insertions, 70 deletions
diff --git a/dev-cpp/rudiments/ChangeLog b/dev-cpp/rudiments/ChangeLog
index d890669963ca..0d281d40f519 100644
--- a/dev-cpp/rudiments/ChangeLog
+++ b/dev-cpp/rudiments/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-cpp/rudiments
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/ChangeLog,v 1.16 2013/02/07 10:16:06 dev-zero Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/ChangeLog,v 1.17 2014/05/03 22:40:26 pinkbyte Exp $
+
+*rudiments-0.46 (03 May 2014)
+
+ 03 May 2014; Sergey Popov <pinkbyte@gentoo.org> -rudiments-0.31.ebuild,
+ -rudiments-0.32.ebuild, +rudiments-0.46.ebuild,
+ +files/rudiments-0.46-buildsystem.patch:
+ Version bump, wrt bug #488108. Update buildsystem patch - respect CFLAGS,
+ migrate to autotools-utils eclass. Drop old versions
07 Feb 2013; Tiziano Müller <dev-zero@gentoo.org> metadata.xml:
Add upstream remote-id info.
diff --git a/dev-cpp/rudiments/files/rudiments-0.46-buildsystem.patch b/dev-cpp/rudiments/files/rudiments-0.46-buildsystem.patch
new file mode 100644
index 000000000000..60710f0a95b2
--- /dev/null
+++ b/dev-cpp/rudiments/files/rudiments-0.46-buildsystem.patch
@@ -0,0 +1,88 @@
+diff --git a/config.mk.in b/config.mk.in
+index ae29f27..c0b7e3d 100644
+--- a/config.mk.in
++++ b/config.mk.in
+@@ -11,7 +11,7 @@ includedir = @includedir@
+ libdir = @libdir@
+ mandir = @mandir@
+ datadir = @datadir@
+-docdir = ${datadir}/doc/rudiments
++docdir = @docdir@
+
+ # compiler to use
+ CC = @CC@
+@@ -21,7 +21,7 @@
+ AR = @AR@
+
+ # includes and defines
+-BASECPPFLAGS = @WALL@ @WERROR@ @CPPFLAGS@ @PTHREADINCLUDES@ @SSLINCLUDES@ @PCREINCLUDES@
++BASECPPFLAGS = @WALL@ @CPPFLAGS@ @PTHREADINCLUDES@ @SSLINCLUDES@ @PCREINCLUDES@
+
+ # debug and optimization flags (-g, -O2, etc.)
+ # NOTE: -FPIC gets added if we're not using libtool
+diff --git a/configure.in b/configure.in
+index d82ea0e..290a80b 100644
+--- a/configure.in
++++ b/configure.in
+@@ -28,7 +28,7 @@ AC_ARG_WITH(pthread-prefix,
+ PTHREADPATH="")
+ AC_ARG_ENABLE(ssl,
+ [ --disable-ssl Disable SSL support],
+- ENABLE_RUDIMENTS_SSL="no",
++ ENABLE_RUDIMENTS_SSL="$enableval",
+ ENABLE_RUDIMENTS_SSL="yes")
+ AC_ARG_WITH(ssl-includes,
+ [ --with-ssl-includes SSL includes],
+@@ -40,7 +40,7 @@ AC_ARG_WITH(ssl-libs,
+ SSLLIBS="")
+ AC_ARG_ENABLE(pcre,
+ [ --disable-pcre Don't use PCRE for regular expressions],
+- ENABLE_RUDIMENTS_PCRE="no",
++ ENABLE_RUDIMENTS_PCRE="$enableval",
+ ENABLE_RUDIMENTS_PCRE="yes")
+ AC_ARG_WITH(pcre-includes,
+ [ --with-pcre-includes PCRE includes],
+@@ -56,7 +56,7 @@ AC_ARG_ENABLE(built-in-regex,
+ USE_BUILT_IN_REGULAREXPRESSION="0")
+ AC_ARG_ENABLE(threads,
+ [ --disable-threads Disable thread support],
+- ENABLE_RUDIMENTS_THREADS="no"; INCLUDE_THREAD="0"; INCLUDE_THREADMUTEX="0",
++ ENABLE_RUDIMENTS_THREADS="$enableval"; INCLUDE_THREAD="0"; INCLUDE_THREADMUTEX="0",
+ ENABLE_RUDIMENTS_THREADS="yes")
+
+ dnl options to disable building various classes
+@@ -3716,6 +3716,10 @@ if ( test "`echo $datadir | cut -c1`" = "/" )
+ then
+ datadir='${DESTDIR}'"$datadir"
+ fi
++if ( test "`echo $docdir | cut -c1`" = "/" )
++then
++ docdir='${DESTDIR}'"$docdir"
++fi
+
+
+ dnl Output files.
+diff --git a/src/Makefile.in b/src/Makefile.in
+index a224d83..3b990fb 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -4,7 +4,7 @@ include ../config.mk
+
+ .PHONY: all clean install uninstall
+
+-CPPFLAGS = $(WERROR) $(BASECPPFLAGS) -I../ -I../include @EXTRACPPFLAGS@
++CPPFLAGS = $(BASECPPFLAGS) -I../ -I../include @EXTRACPPFLAGS@
+
+ SRCS = namevaluepairs.cpp winsock.cpp @SRCS@
+ LOBJS = namevaluepairs.lo winsock.lo @LOBJS@
+--- a/acsite.m4 2014-05-04 01:44:03.265919456 +0400
++++ b/acsite.m4 2014-05-04 01:44:34.008920936 +0400
+@@ -266,7 +237,7 @@
+ dnl Sometimes -Wall includes -Wunused-variables and -Wunused-parameters
+ dnl which we don't care about. Disable it if it does.
+ OLDCPPFLAGS=$CPPFLAGS
+- CPPFLAGS="$WALL $WERROR $CPPFLAGS"
++ CPPFLAGS="$WALL $CPPFLAGS"
+ AC_MSG_CHECKING(whether -Wall includes -Wunused-*)
+ AC_TRY_COMPILE([void f(int a) { return; }],[f(1);],AC_MSG_RESULT(no),WALL=""; AC_MSG_RESULT(yes))
+ CPPFLAGS=$OLDCPPFLAGS
diff --git a/dev-cpp/rudiments/rudiments-0.31.ebuild b/dev-cpp/rudiments/rudiments-0.31.ebuild
deleted file mode 100644
index 5a2ff75672c3..000000000000
--- a/dev-cpp/rudiments/rudiments-0.31.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/rudiments-0.31.ebuild,v 1.1 2008/04/04 01:10:49 halcy0n Exp $
-
-DESCRIPTION="C++ class library for daemons, clients and servers"
-HOMEPAGE="http://rudiments.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rudiments/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="debug pcre ssl"
-
-DEPEND="pcre? ( dev-libs/libpcre )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- # It's a buggy configure-script
- # We can only disable, but not enable
- local options
- use pcre || options="${options} --disable-pcre"
- use ssl || options="${options} --disable-ssl"
- econf \
- $(use_enable debug) \
- ${options} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}/html" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/dev-cpp/rudiments/rudiments-0.32.ebuild b/dev-cpp/rudiments/rudiments-0.32.ebuild
deleted file mode 100644
index 53c0ec95710a..000000000000
--- a/dev-cpp/rudiments/rudiments-0.32.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/rudiments-0.32.ebuild,v 1.1 2009/05/19 13:55:46 matsuu Exp $
-
-DESCRIPTION="C++ class library for daemons, clients and servers"
-HOMEPAGE="http://rudiments.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rudiments/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug pcre ssl"
-
-DEPEND="pcre? ( dev-libs/libpcre )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- # It's a buggy configure-script
- # We can only disable, but not enable
- local options
- use pcre || options="${options} --disable-pcre"
- use ssl || options="${options} --disable-ssl"
- econf \
- $(use_enable debug) \
- ${options} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}/html" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/dev-cpp/rudiments/rudiments-0.46.ebuild b/dev-cpp/rudiments/rudiments-0.46.ebuild
new file mode 100644
index 000000000000..6b9973f071dc
--- /dev/null
+++ b/dev-cpp/rudiments/rudiments-0.46.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/rudiments-0.46.ebuild,v 1.1 2014/05/03 22:40:26 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="C++ class library for daemons, clients and servers"
+HOMEPAGE="http://rudiments.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rudiments/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug pcre ssl static-libs"
+
+DEPEND="pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-buildsystem.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="/usr/share/doc/${PF}/html" \
+ $(use debug && "--enable-debug") \
+ $(use_enable pcre) \
+ $(use_enable ssl)
+ )
+ autotools-utils_src_configure
+}