summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-09 05:22:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-09 05:22:01 +0000
commitc87e334e2708b682f2135b3b533d6e9808382650 (patch)
treea5c94a2d3381e05000571dc60bc1e33200dc3f8f /dev-cpp/libxsd-frontend
parentMask a revbump for libxsd-frontend to handle the new boost layout in 1.52.0-r1. (diff)
downloadgentoo-2-c87e334e2708b682f2135b3b533d6e9808382650.tar.gz
gentoo-2-c87e334e2708b682f2135b3b533d6e9808382650.tar.bz2
gentoo-2-c87e334e2708b682f2135b3b533d6e9808382650.zip
Add a masked revision bump to leverage the layout changes in boost-1.52.0-r1.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-cpp/libxsd-frontend')
-rw-r--r--dev-cpp/libxsd-frontend/ChangeLog8
-rw-r--r--dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r1.ebuild92
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-cpp/libxsd-frontend/ChangeLog b/dev-cpp/libxsd-frontend/ChangeLog
index 20c97491a7fe..579494750135 100644
--- a/dev-cpp/libxsd-frontend/ChangeLog
+++ b/dev-cpp/libxsd-frontend/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libxsd-frontend
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxsd-frontend/ChangeLog,v 1.5 2012/10/17 18:53:35 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxsd-frontend/ChangeLog,v 1.6 2012/11/09 05:22:01 flameeyes Exp $
+
+*libxsd-frontend-1.18.0-r1 (09 Nov 2012)
+
+ 09 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libxsd-frontend-1.18.0-r1.ebuild:
+ Add a masked revision bump to leverage the layout changes in boost-1.52.0-r1.
17 Oct 2012; Markus Meier <maekke@gentoo.org> libxsd-frontend-1.18.0.ebuild:
add ~arm, bug #430072
diff --git a/dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r1.ebuild b/dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r1.ebuild
new file mode 100644
index 000000000000..f77353d76643
--- /dev/null
+++ b/dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r1.ebuild,v 1.1 2012/11/09 05:22:01 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs versionator
+
+DESCRIPTION="A compiler frontend for the W3C XML Schema definition language."
+HOMEPAGE="http://www.codesynthesis.com/projects/libxsd-frontend/"
+SRC_URI="http://www.codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/xerces-c-3
+ >=dev-libs/boost-1.52.0-r1[threads]
+ >=dev-cpp/libcult-1.4.6-r1
+ >=dev-cpp/libfrontend-elements-1.1.4"
+DEPEND="${RDEPEND}
+ dev-util/build:0.3"
+
+src_prepare() {
+ epatch "${FILESDIR}/1.17.0-boost-filesystem-v2-deprecation.patch"
+}
+
+src_configure() {
+ mkdir -p \
+ build/{ld,cxx/gnu} \
+ build/import/lib{boost,cult,frontend-elements,xerces-c}
+
+ cat >> build/cxx/configuration-dynamic.make <<- EOF
+cxx_id := gnu
+cxx_optimize := n
+cxx_debug := n
+cxx_rpath := n
+cxx_pp_extra_options :=
+cxx_extra_options := ${CXXFLAGS}
+cxx_ld_extra_options := ${LDFLAGS}
+cxx_extra_libs :=
+cxx_extra_lib_paths :=
+ EOF
+
+ cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF
+cxx_gnu := $(tc-getCXX)
+cxx_gnu_libraries :=
+cxx_gnu_optimization_options :=
+ EOF
+
+ cat >> build/import/libboost/configuration-dynamic.make <<- EOF
+libboost_installed := y
+ EOF
+ cat >> build/import/libcult/configuration-dynamic.make <<- EOF
+libcult_installed := y
+ EOF
+
+ cat >> build/ld/configuration-lib-dynamic.make <<- EOF
+ld_lib_type := shared
+ EOF
+
+ cat >> build/import/libfrontend-elements/configuration-dynamic.make <<- EOF
+libfrontend_elements_installed := y
+ EOF
+
+ cat >> build/import/libxerces-c/configuration-dynamic.make <<- EOF
+libxerces_c_installed := y
+ EOF
+
+ MAKEOPTS+=" verbose=1"
+}
+
+src_install() {
+ dolib.so xsd-frontend/libxsd-frontend.so
+
+ find xsd-frontend -iname "*.cxx" \
+ -o -iname "makefile" \
+ -o -iname "*.o" -o -iname "*.d" \
+ -o -iname "*.m4" -o -iname "*.l" \
+ -o -iname "*.cpp-options" -o -iname "*.so" | xargs rm -f
+ rm -rf xsd-frontend/arch
+
+ insinto /usr/include
+ doins -r xsd-frontend
+
+ dodoc NEWS README
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/xsd-frontend:${LD_LIBRARY_PATH}"
+ default
+}