summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-12-12 03:16:36 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-12-12 03:16:36 +0000
commitc427c396f775f06405cd332b4baf15dc99150163 (patch)
treeb5ad41c913030680a83e4b8619951e3a366bac72 /app-vim
parentVersion bump with improvements for bug 343127 by Roman v. Gemmeren (diff)
downloadgentoo-2-c427c396f775f06405cd332b4baf15dc99150163.tar.gz
gentoo-2-c427c396f775f06405cd332b4baf15dc99150163.tar.bz2
gentoo-2-c427c396f775f06405cd332b4baf15dc99150163.zip
Version bump to fix bugs: 322247, 319809, 322871, 329311, 346477, 281481, and other fixes
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/ChangeLog9
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20101212.ebuild47
2 files changed, 55 insertions, 1 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index e750728a3c21..f33f14523914 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.124 2010/10/14 09:44:58 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.125 2010/12/12 03:16:36 darkside Exp $
+
+*gentoo-syntax-20101212 (12 Dec 2010)
+
+ 12 Dec 2010; Jeremy Olexa <darkside@gentoo.org>
+ +gentoo-syntax-20101212.ebuild:
+ Version bump to fix bugs: 322247, 319809, 322871, 329311, 346477, 281481,
+ and other fixes
14 Oct 2010; Fabian Groffen <grobian@gentoo.org>
gentoo-syntax-20100215.ebuild:
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20101212.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20101212.ebuild
new file mode 100644
index 000000000000..b98103b15cff
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20101212.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20101212.ebuild,v 1.1 2010/12/12 03:16:36 darkside Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ echo
+}