summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-04 04:27:06 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-04 04:27:06 +0000
commitbf0ce7fc1df8f7eb0742237cb347be0376b5bf8e (patch)
tree5eadbec877caa20924a00896bacaa25c8513e5ad /app-vim/vim-latex
parentMove Qt mask into bsd/ darwin/ and sunos/ to unmask on linux (diff)
downloadgentoo-2-bf0ce7fc1df8f7eb0742237cb347be0376b5bf8e.tar.gz
gentoo-2-bf0ce7fc1df8f7eb0742237cb347be0376b5bf8e.tar.bz2
gentoo-2-bf0ce7fc1df8f7eb0742237cb347be0376b5bf8e.zip
Version bump
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/vim-latex')
-rw-r--r--app-vim/vim-latex/ChangeLog8
-rw-r--r--app-vim/vim-latex/vim-latex-1.8.23.20110214.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/app-vim/vim-latex/ChangeLog b/app-vim/vim-latex/ChangeLog
index facdd61dc22f..1ccc9f5590b8 100644
--- a/app-vim/vim-latex/ChangeLog
+++ b/app-vim/vim-latex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/vim-latex
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-latex/ChangeLog,v 1.1 2011/01/24 06:32:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-latex/ChangeLog,v 1.2 2011/03/04 04:27:06 radhermit Exp $
+
+*vim-latex-1.8.23.20110214 (04 Mar 2011)
+
+ 04 Mar 2011; Tim Harder <radhermit@gentoo.org>
+ +vim-latex-1.8.23.20110214.ebuild:
+ Version bump
24 Jan 2011; Tim Harder <radhermit@gentoo.org>
+vim-latex-1.8.23.20100129.ebuild, +vim-latex-1.8.23.20101027.ebuild,
diff --git a/app-vim/vim-latex/vim-latex-1.8.23.20110214.ebuild b/app-vim/vim-latex/vim-latex-1.8.23.20110214.ebuild
new file mode 100644
index 000000000000..6bea5a6bdc1a
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.8.23.20110214.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-latex/vim-latex-1.8.23.20110214.ebuild,v 1.1 2011/03/04 04:27:06 radhermit Exp $
+
+EAPI=3
+
+inherit vim-plugin versionator
+
+MY_REV="1049-git089726a"
+MY_P="${PN}-$( replace_version_separator 3 - ).${MY_REV}"
+
+DESCRIPTION="vim plugin: a comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="html"
+
+RDEPEND="virtual/latex-base"
+
+S="${WORKDIR}/${MY_P}"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_prepare() {
+ # The makefiles do weird stuff, including running the svn command
+ rm Makefile Makefile.in || die "rm Makefile Makefile.in failed"
+}
+
+src_install() {
+ use html && dohtml -r doc/
+
+ # Don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # Don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # Use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ elog
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ elog
+}