summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-08-20 01:49:38 +0000
committerSteve Dibb <beandog@gentoo.org>2008-08-20 01:49:38 +0000
commitf886805ce1d6655895068931b3590efaa4396f03 (patch)
tree489fd0c3b4d4c755374348671fbd28c467c167ad /app-text
parentVersion bump. (diff)
downloadgentoo-2-f886805ce1d6655895068931b3590efaa4396f03.tar.gz
gentoo-2-f886805ce1d6655895068931b3590efaa4396f03.tar.bz2
gentoo-2-f886805ce1d6655895068931b3590efaa4396f03.zip
Version bump, bug 232376
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-tuxonice x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gnomesword/ChangeLog9
-rw-r--r--app-text/gnomesword/gnomesword-2.3.5.ebuild51
-rw-r--r--app-text/gnomesword/gnomesword-2.3.6.ebuild51
3 files changed, 110 insertions, 1 deletions
diff --git a/app-text/gnomesword/ChangeLog b/app-text/gnomesword/ChangeLog
index 3409d9a05ddd..aeb948b13c5e 100644
--- a/app-text/gnomesword/ChangeLog
+++ b/app-text/gnomesword/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gnomesword
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/ChangeLog,v 1.29 2008/06/26 01:47:25 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/ChangeLog,v 1.30 2008/08/20 01:49:38 beandog Exp $
+
+*gnomesword-2.3.6 (20 Aug 2008)
+*gnomesword-2.3.5 (20 Aug 2008)
+
+ 20 Aug 2008; Steve Dibb <beandog@gentoo.org> +gnomesword-2.3.5.ebuild,
+ +gnomesword-2.3.6.ebuild:
+ Version bump, bug 232376
*gnomesword-2.3.1-r2 (26 Jun 2008)
diff --git a/app-text/gnomesword/gnomesword-2.3.5.ebuild b/app-text/gnomesword/gnomesword-2.3.5.ebuild
new file mode 100644
index 000000000000..a61dbd3fbafd
--- /dev/null
+++ b/app-text/gnomesword/gnomesword-2.3.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/gnomesword-2.3.5.ebuild,v 1.1 2008/08/20 01:49:38 beandog Exp $
+
+inherit libtool gnome2 eutils
+
+DESCRIPTION="Gnome Bible study software"
+HOMEPAGE="http://gnomesword.sf.net/"
+SRC_URI="mirror://sourceforge/gnomesword/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="firefox seamonkey spell xulrunner"
+RDEPEND=">=gnome-extra/gtkhtml-3.14
+ =app-text/sword-1.5.11*
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libglade-2
+ app-text/gnome-doc-utils
+ dev-libs/libxml2
+ xulrunner? ( =net-libs/xulrunner-1.8* )
+ !xulrunner? ( firefox? ( =www-client/mozilla-firefox-2* ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( =www-client/seamonkey-1* ) ) )
+ spell? (
+ app-text/gnome-spell
+ >=gnome-base/libbonoboui-2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.3.14"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable spell pspell)"
+ DOCS="NEWS ChangeLog README TODO"
+}
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+ # bug 226659
+ epatch "${FILESDIR}/${PN}-gcc43.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Gnomesword requires modules to be of any use. You may install the"
+ einfo "sword-modules package, or download modules individually from the"
+ einfo "sword website: http://crosswire.org/sword/"
+}
diff --git a/app-text/gnomesword/gnomesword-2.3.6.ebuild b/app-text/gnomesword/gnomesword-2.3.6.ebuild
new file mode 100644
index 000000000000..68a21bfee697
--- /dev/null
+++ b/app-text/gnomesword/gnomesword-2.3.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/gnomesword-2.3.6.ebuild,v 1.1 2008/08/20 01:49:38 beandog Exp $
+
+inherit libtool gnome2 eutils
+
+DESCRIPTION="Gnome Bible study software"
+HOMEPAGE="http://gnomesword.sf.net/"
+SRC_URI="mirror://sourceforge/gnomesword/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="firefox seamonkey spell xulrunner"
+RDEPEND=">=gnome-extra/gtkhtml-3.14
+ =app-text/sword-1.5.11*
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libglade-2
+ app-text/gnome-doc-utils
+ dev-libs/libxml2
+ xulrunner? ( =net-libs/xulrunner-1.8* )
+ !xulrunner? ( firefox? ( =www-client/mozilla-firefox-2* ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( =www-client/seamonkey-1* ) ) )
+ spell? (
+ app-text/gnome-spell
+ >=gnome-base/libbonoboui-2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.3.14"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable spell pspell)"
+ DOCS="NEWS ChangeLog README TODO"
+}
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+ # bug 226659
+ epatch "${FILESDIR}/${PN}-gcc43.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Gnomesword requires modules to be of any use. You may install the"
+ einfo "sword-modules package, or download modules individually from the"
+ einfo "sword website: http://crosswire.org/sword/"
+}