summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-01 23:54:36 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-01 23:54:36 +0000
commitbd04a9f0c701f11d0f77f27190aed08bcefd13d9 (patch)
treec4ffc18a65d2ad3f08e85a6faf0d0f11f8bb904b /app-text
parentVersion bumped. Respect CFLAGS="-O?", bug #369339. (diff)
downloadgentoo-2-bd04a9f0c701f11d0f77f27190aed08bcefd13d9.tar.gz
gentoo-2-bd04a9f0c701f11d0f77f27190aed08bcefd13d9.tar.bz2
gentoo-2-bd04a9f0c701f11d0f77f27190aed08bcefd13d9.zip
Version bump and remove old.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/highlight/ChangeLog8
-rw-r--r--app-text/highlight/highlight-3.4.ebuild (renamed from app-text/highlight/highlight-3.0_beta.ebuild)45
2 files changed, 26 insertions, 27 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index 57fbbf6e304e..f9edc50902ae 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/highlight
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.35 2011/02/09 11:48:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.36 2011/06/01 23:54:36 radhermit Exp $
+
+*highlight-3.4 (01 Jun 2011)
+
+ 01 Jun 2011; Tim Harder <radhermit@gentoo.org> -highlight-3.0_beta.ebuild,
+ +highlight-3.4.ebuild:
+ Version bump and remove old.
09 Feb 2011; Tim Harder <radhermit@gentoo.org> highlight-3.3.ebuild:
Add dev-libs/boost to DEPEND.
diff --git a/app-text/highlight/highlight-3.0_beta.ebuild b/app-text/highlight/highlight-3.4.ebuild
index 02e29194fba7..2341dc9dd132 100644
--- a/app-text/highlight/highlight-3.0_beta.ebuild
+++ b/app-text/highlight/highlight-3.4.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.0_beta.ebuild,v 1.1 2010/06/19 08:16:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.4.ebuild,v 1.1 2011/06/01 23:54:36 radhermit Exp $
-EAPI=3
-inherit toolchain-funcs
+EAPI=4
-MY_P=${P/_/-}
+inherit toolchain-funcs
DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
HOMEPAGE="http://www.andre-simon.de/"
-SRC_URI="http://www.andre-simon.de/zip/${MY_P}.tar.bz2"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="qt4"
+IUSE="examples qt4"
DEPEND="dev-lang/lua
+ dev-libs/boost
qt4? ( x11-libs/qt-gui:4 )"
-
-S=${WORKDIR}/${MY_P}
+RDEPEND="${DEPEND}"
pkg_setup() {
myhlopts=(
@@ -28,36 +27,30 @@ pkg_setup() {
"PREFIX=${EPREFIX}/usr"
"doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
"conf_dir=${EPREFIX}/etc/highlight/"
- )
+ )
}
src_prepare() {
- sed -i \
- -e 's:dir}plugins:dir}web_plugins:' \
- makefile || die
-
- sed -i \
- -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
src/core/datadir.cpp || die
- sed -i \
- -e 's:-O2::' \
+ sed -i -e 's:-O2::' \
-e 's:CFLAGS:CXXFLAGS:g' \
src/makefile || die
}
src_compile() {
- emake -f makefile "${myhlopts[@]}" || die
-
- if use qt4; then
- emake -j1 -f makefile "${myhlopts[@]}" gui || die
- fi
+ emake -f makefile "${myhlopts[@]}"
+ use qt4 && emake -f makefile "${myhlopts[@]}" gui
}
src_install() {
- emake -f makefile "${myhlopts[@]}" install || die
+ emake -f makefile "${myhlopts[@]}" install
+ use qt4 && emake -f makefile "${myhlopts[@]}" install-gui
- if use qt4; then
- emake -f makefile "${myhlopts[@]}" install-gui || die
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -rf "${D}"/usr/share/doc/${PF}/examples
fi
}