summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-13 10:39:44 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-13 10:39:44 +0000
commitba504c92721999572bb055fa5744ecd3e8a88417 (patch)
treeca444d7481b382441b3b32f2f74ef8fe1e157d57 /app-text
parentAdd perl-5.18 and -20 version (diff)
downloadgentoo-2-ba504c92721999572bb055fa5744ecd3e8a88417.tar.gz
gentoo-2-ba504c92721999572bb055fa5744ecd3e8a88417.tar.bz2
gentoo-2-ba504c92721999572bb055fa5744ecd3e8a88417.zip
Remove workaround on freetype, this is fixed in current stable dev-util/cmake-2.8.12.2, bug #459394.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/ChangeLog7
-rw-r--r--app-text/poppler/poppler-0.26.1.ebuild102
-rw-r--r--app-text/poppler/poppler-0.26.2.ebuild11
-rw-r--r--app-text/poppler/poppler-9999.ebuild11
4 files changed, 10 insertions, 121 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index 0ec2201e4b6c..d9260b3864bb 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.426 2014/06/22 18:57:56 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.427 2014/07/13 10:39:44 johu Exp $
+
+ 13 Jul 2014; Johannes Huber <johu@gentoo.org> -poppler-0.26.1.ebuild,
+ poppler-0.26.2.ebuild, poppler-9999.ebuild:
+ Remove workaround on freetype, this is fixed in current stable dev-
+ util/cmake-2.8.12.2, bug #459394.
*poppler-9999 (22 Jun 2014)
*poppler-0.26.2 (22 Jun 2014)
diff --git a/app-text/poppler/poppler-0.26.1.ebuild b/app-text/poppler/poppler-0.26.1.ebuild
deleted file mode 100644
index becb8eeaf85c..000000000000
--- a/app-text/poppler/poppler-0.26.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.26.1.ebuild,v 1.1 2014/05/23 22:49:52 dilfridge Exp $
-
-EAPI=5
-
-inherit cmake-utils toolchain-funcs
-
-DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
-HOMEPAGE="http://poppler.freedesktop.org/"
-SRC_URI="http://poppler.freedesktop.org/${P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0/46"
-IUSE="cairo cjk curl cxx debug doc +introspection +jpeg jpeg2k +lcms png qt4 qt5 tiff +utils"
-
-# No test data provided
-RESTRICT="test"
-
-COMMON_DEPEND="
- >=media-libs/fontconfig-2.6.0
- >=media-libs/freetype-2.3.9
- sys-libs/zlib
- cairo? (
- dev-libs/glib:2
- >=x11-libs/cairo-1.10.0
- introspection? ( >=dev-libs/gobject-introspection-1.32.1 )
- )
- curl? ( net-misc/curl )
- jpeg? ( virtual/jpeg:0 )
- jpeg2k? ( media-libs/openjpeg:0 )
- lcms? ( media-libs/lcms:2 )
- png? ( media-libs/libpng:0= )
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtxml:5
- )
- tiff? ( media-libs/tiff:0 )
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}
- cjk? ( >=app-text/poppler-data-0.4.4 )
-"
-
-DOCS=(AUTHORS NEWS README README-XPDF TODO)
-
-PATCHES=( "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch" )
-
-src_configure() {
- # this is needed for multilib, see bug 459394
- local ft_libdir ft_includedir
- ft_libdir="$($(tc-getPKG_CONFIG) freetype2 --variable=libdir)"
- ft_includedir="$($(tc-getPKG_CONFIG) freetype2 --variable=includedir)"
- export FREETYPE_DIR="${ft_libdir}:${ft_includedir%/include}"
- einfo "Detected FreeType at ${FREETYPE_DIR}"
-
- mycmakeargs=(
- -DBUILD_GTK_TESTS=OFF
- -DBUILD_QT4_TESTS=OFF
- -DBUILD_QT5_TESTS=OFF
- -DBUILD_CPP_TESTS=OFF
- -DENABLE_SPLASH=ON
- -DENABLE_ZLIB=ON
- -DENABLE_XPDF_HEADERS=ON
- $(cmake-utils_use_enable curl LIBCURL)
- $(cmake-utils_use_enable cxx CPP)
- $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
- $(cmake-utils_use_enable utils)
- $(cmake-utils_use_with cairo)
- $(cmake-utils_use_with introspection GObjectIntrospection)
- $(cmake-utils_use_with jpeg)
- $(cmake-utils_use_with png)
- $(cmake-utils_use_with qt4)
- $(cmake-utils_use_find_package qt5 Qt5Core)
- $(cmake-utils_use_with tiff)
- )
- if use lcms; then
- mycmakeargs+=(-DENABLE_CMS=lcms2)
- else
- mycmakeargs+=(-DENABLE_CMS=)
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use cairo && use doc; then
- # For now install gtk-doc there
- insinto /usr/share/gtk-doc/html/poppler
- doins -r "${S}"/glib/reference/html/*
- fi
-}
diff --git a/app-text/poppler/poppler-0.26.2.ebuild b/app-text/poppler/poppler-0.26.2.ebuild
index f2e6056bf8f0..681080b41f13 100644
--- a/app-text/poppler/poppler-0.26.2.ebuild
+++ b/app-text/poppler/poppler-0.26.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.26.2.ebuild,v 1.1 2014/06/22 18:57:56 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.26.2.ebuild,v 1.2 2014/07/13 10:39:44 johu Exp $
EAPI=5
@@ -63,14 +63,7 @@ DOCS=(AUTHORS NEWS README README-XPDF TODO)
PATCHES=( "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch" )
src_configure() {
- # this is needed for multilib, see bug 459394
- local ft_libdir ft_includedir
- ft_libdir="$($(tc-getPKG_CONFIG) freetype2 --variable=libdir)"
- ft_includedir="$($(tc-getPKG_CONFIG) freetype2 --variable=includedir)"
- export FREETYPE_DIR="${ft_libdir}:${ft_includedir%/include}"
- einfo "Detected FreeType at ${FREETYPE_DIR}"
-
- mycmakeargs=(
+ local mycmakeargs=(
-DBUILD_GTK_TESTS=OFF
-DBUILD_QT4_TESTS=OFF
-DBUILD_QT5_TESTS=OFF
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 4fb7d83fcb47..3e0770aafde7 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-9999.ebuild,v 1.1 2014/06/22 18:57:56 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-9999.ebuild,v 1.2 2014/07/13 10:39:44 johu Exp $
EAPI=5
@@ -63,14 +63,7 @@ DOCS=(AUTHORS NEWS README README-XPDF TODO)
PATCHES=( "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch" )
src_configure() {
- # this is needed for multilib, see bug 459394
- local ft_libdir ft_includedir
- ft_libdir="$($(tc-getPKG_CONFIG) freetype2 --variable=libdir)"
- ft_includedir="$($(tc-getPKG_CONFIG) freetype2 --variable=includedir)"
- export FREETYPE_DIR="${ft_libdir}:${ft_includedir%/include}"
- einfo "Detected FreeType at ${FREETYPE_DIR}"
-
- mycmakeargs=(
+ local mycmakeargs=(
-DBUILD_GTK_TESTS=OFF
-DBUILD_QT4_TESTS=OFF
-DBUILD_QT5_TESTS=OFF