summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-06-01 12:31:41 +0000
committerMichael Weber <xmw@gentoo.org>2015-06-01 12:31:41 +0000
commit707e55d1c4db49a6a86e761b569bbc3514b13823 (patch)
tree1450e3f28099dc52189dca433ddf005dda8c1c4b /app-text
parentAdd keywords (diff)
downloadgentoo-2-707e55d1c4db49a6a86e761b569bbc3514b13823.tar.gz
gentoo-2-707e55d1c4db49a6a86e761b569bbc3514b13823.tar.bz2
gentoo-2-707e55d1c4db49a6a86e761b569bbc3514b13823.zip
Enable javascript support (bug 550286, Cedric Sodhi).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/mupdf/ChangeLog6
-rw-r--r--app-text/mupdf/files/mupdf-1.7a-system-mujs.patch11
-rw-r--r--app-text/mupdf/mupdf-1.7a.ebuild13
3 files changed, 25 insertions, 5 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index 6cef49095ba9..2aad53d51641 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.117 2015/05/20 15:08:10 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.118 2015/06/01 12:31:41 xmw Exp $
+
+ 01 Jun 2015; Michael Weber <xmw@gentoo.org>
+ +files/mupdf-1.7a-system-mujs.patch, mupdf-1.7a.ebuild:
+ Enable javascript support (bug 550286, Cedric Sodhi).
*mupdf-1.7a (20 May 2015)
diff --git a/app-text/mupdf/files/mupdf-1.7a-system-mujs.patch b/app-text/mupdf/files/mupdf-1.7a-system-mujs.patch
new file mode 100644
index 000000000000..1ccaf32d79bb
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.7a-system-mujs.patch
@@ -0,0 +1,11 @@
+--- mupdf-1.7a/Makefile
++++ mupdf-1.7a/Makefile
+@@ -98,7 +98,7 @@
+ ifeq "$(HAVE_MUJS)" "yes"
+ PDF_OBJ += $(OUT)/pdf/js/pdf-js.o
+ PDF_OBJ += $(OUT)/pdf/js/pdf-jsimp-mu.o
+-THIRD_LIBS += $(MUJS_LIB)
++THIRD_LIBS +=
+ LIBS += $(MUJS_LIBS)
+ CFLAGS += $(MUJS_CFLAGS)
+ else ifeq "$(HAVE_JSCORE)" "yes"
diff --git a/app-text/mupdf/mupdf-1.7a.ebuild b/app-text/mupdf/mupdf-1.7a.ebuild
index d7f691a21d77..737f01ca6436 100644
--- a/app-text/mupdf/mupdf-1.7a.ebuild
+++ b/app-text/mupdf/mupdf-1.7a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-1.7a.ebuild,v 1.1 2015/05/20 15:08:10 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-1.7a.ebuild,v 1.2 2015/06/01 12:31:41 xmw Exp $
EAPI=5
@@ -14,7 +14,7 @@ LICENSE="AGPL-3"
MY_SOVER=1.7
SLOT="0/${MY_SOVER}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="X vanilla +curl +openssl static static-libs"
+IUSE="X vanilla +curl javascript +openssl static static-libs"
LIB_DEPEND="dev-libs/openssl[static-libs?]
media-libs/freetype:2[static-libs?]
@@ -23,7 +23,8 @@ LIB_DEPEND="dev-libs/openssl[static-libs?]
net-misc/curl[static-libs?]
virtual/jpeg[static-libs?]
X? ( x11-libs/libX11[static-libs?]
- x11-libs/libXext[static-libs?] )"
+ x11-libs/libXext[static-libs?] )
+ javascript? ( dev-lang/mujs )"
RDEPEND="${LIB_DEPEND}"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -41,7 +42,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.3-CFLAGS.patch \
"${FILESDIR}"/${PN}-1.5-old-debian-files.patch \
"${FILESDIR}"/${PN}-1.3-pkg-config.patch \
- "${FILESDIR}"/${PN}-1.5-Makerules-openssl-curl.patch
+ "${FILESDIR}"/${PN}-1.5-Makerules-openssl-curl.patch \
+ "${FILESDIR}"/${PN}-1.7a-system-mujs.patch
if has_version ">=media-libs/openjpeg-2.1:2" ; then
epatch \
@@ -71,6 +73,9 @@ src_prepare() {
-e "1iHAVE_X11 = $(usex X)" \
-e "1iWANT_OPENSSL = $(usex openssl)" \
-e "1iWANT_CURL = $(usex curl)" \
+ -e "1iHAVE_MUJS = $(usex javascript)" \
+ -e "1iMUJS_LIBS = -lmujs" \
+ -e "1iMUJS_CFLAGS =" \
-i Makerules || die
if use static-libs || use static ; then