summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-03 21:48:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-03 21:48:00 +0000
commit4081ae60684be67a28bb4d378ff37b98b5353550 (patch)
tree355029e23f9e96ff6589bd91cb9107e2f8a5aa70 /app-text
parentx86 stable, bug #301404 (diff)
downloadgentoo-2-4081ae60684be67a28bb4d378ff37b98b5353550.tar.gz
gentoo-2-4081ae60684be67a28bb4d378ff37b98b5353550.tar.bz2
gentoo-2-4081ae60684be67a28bb4d378ff37b98b5353550.zip
Adding as-needed patch, fixing 274700, thanks idl0r and Gef Lebster for
providing patches (Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/multitail/ChangeLog11
-rw-r--r--app-text/multitail/files/5.2.2-as-needed.patch26
-rw-r--r--app-text/multitail/multitail-5.2.2-r1.ebuild47
3 files changed, 82 insertions, 2 deletions
diff --git a/app-text/multitail/ChangeLog b/app-text/multitail/ChangeLog
index 03be9ca8f44e..e8470fe00876 100644
--- a/app-text/multitail/ChangeLog
+++ b/app-text/multitail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/multitail
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.70 2009/08/01 17:49:09 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.71 2010/02/03 21:47:59 jlec Exp $
+
+*multitail-5.2.2-r1 (03 Feb 2010)
+
+ 03 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/5.2.2-as-needed.patch, +multitail-5.2.2-r1.ebuild:
+ Adding as-needed patch, fixing 274700, thanks idl0r and Gef Lebster for
+ providing patches
01 Aug 2009; Jeremy Olexa <darkside@gentoo.org> -multitail-4.2.0.ebuild,
-multitail-5.2.0.ebuild, -multitail-5.2.1.ebuild:
diff --git a/app-text/multitail/files/5.2.2-as-needed.patch b/app-text/multitail/files/5.2.2-as-needed.patch
new file mode 100644
index 000000000000..d9ad7660aed9
--- /dev/null
+++ b/app-text/multitail/files/5.2.2-as-needed.patch
@@ -0,0 +1,26 @@
+--- Makefile.old 2009-07-02 20:16:52.561919791 +0200
++++ Makefile 2009-07-02 20:17:21.947666469 +0200
+@@ -4,19 +4,19 @@ DESTDIR=/
+ CONFIG_FILE=$(DESTDIR)/etc/multitail.conf
+
+ DEBUG=-g # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
+-LDFLAGS+=-lpanel -lncurses -lutil -lm $(DEBUG) -rdynamic
++LIBS+=-lpanel -lncurses -lutil -lm
+ # LDFLAGS+=-lc_p -lpanel_g -lncurses_g -lutil -lm -pg -g -rdynamic
+-CFLAGS+=-funsigned-char -D`uname` -O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
++CFLAGS+=-funsigned-char -D`uname` -Wall -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -rdynamic
+
+ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o
+
+ all: multitail
+
+ multitail: $(OBJS)
+- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o multitail
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ multitail_ccmalloc: $(OBJS)
+- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
++ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o ccmultitail $(LIBS)
+
+ install: multitail
+ cp multitail $(DESTDIR)/usr/bin
diff --git a/app-text/multitail/multitail-5.2.2-r1.ebuild b/app-text/multitail/multitail-5.2.2-r1.ebuild
new file mode 100644
index 000000000000..9d7c8350d150
--- /dev/null
+++ b/app-text/multitail/multitail-5.2.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-5.2.2-r1.ebuild,v 1.1 2010/02/03 21:47:59 jlec Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/index.html"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-as-needed.patch"
+}
+
+src_configure() {
+ tc-export CC
+ use debug && append-flags "-D_DEBUG"
+}
+
+src_install () {
+ dobin multitail || die
+
+ insinto /etc
+ doins multitail.conf || die
+
+ dodoc Changes readme.txt thanks.txt || die
+ doman multitail.1 || die
+
+ if use examples; then
+ docinto examples
+ dodoc colors-example.{pl,sh} convert-{geoip,simple}.pl || die
+ fi
+
+ if use doc; then
+ dohtml manual.html || die
+ fi
+}