summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-05-25 00:29:28 +0000
committerBrian Evans <grknight@gentoo.org>2015-05-25 00:29:28 +0000
commit2c53c5f0cf2141a0f09a07f62e847b23d2395297 (patch)
tree6b7b7ff7776b854f4222db6dfd21407ba0469fcc /app-text
parentRemove old. (diff)
downloadgentoo-2-2c53c5f0cf2141a0f09a07f62e847b23d2395297.tar.gz
gentoo-2-2c53c5f0cf2141a0f09a07f62e847b23d2395297.tar.bz2
gentoo-2-2c53c5f0cf2141a0f09a07f62e847b23d2395297.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/groonga/ChangeLog9
-rw-r--r--app-text/groonga/groonga-5.0.3.ebuild92
2 files changed, 99 insertions, 2 deletions
diff --git a/app-text/groonga/ChangeLog b/app-text/groonga/ChangeLog
index f34453121633..1ab9ace9ee5a 100644
--- a/app-text/groonga/ChangeLog
+++ b/app-text/groonga/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/groonga
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/groonga/ChangeLog,v 1.2 2014/12/02 03:20:57 grknight Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/groonga/ChangeLog,v 1.3 2015/05/25 00:29:28 grknight Exp $
+
+*groonga-5.0.3 (25 May 2015)
+
+ 25 May 2015; Brian Evans <grknight@gentoo.org> +groonga-5.0.3.ebuild:
+ Version bump
*groonga-4.0.7-r1 (02 Dec 2014)
diff --git a/app-text/groonga/groonga-5.0.3.ebuild b/app-text/groonga/groonga-5.0.3.ebuild
new file mode 100644
index 000000000000..10b32dbd790a
--- /dev/null
+++ b/app-text/groonga/groonga-5.0.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/groonga/groonga-5.0.3.ebuild,v 1.1 2015/05/25 00:29:28 grknight Exp $
+
+EAPI=5
+
+inherit eutils libtool user
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="abort benchmark debug doc dynamic-malloc-change +exact-alloc-count examples fmalloc futex libedit libevent lzo mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib"
+
+RDEPEND="benchmark? ( >=dev-libs/glib-2.8 )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )"
+
+REQUIRED_USE=" abort? ( dynamic-malloc-change ) fmalloc? ( dynamic-malloc-change ) sphinx? ( doc )"
+
+pkg_setup() {
+ enewgroup groonga
+ enewuser groonga -1 -1 -1 groonga
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # kytea and libstemmer are not available in portage
+ # ruby is only used for an http test
+ econf \
+ --disable-groonga-httpd \
+ --without-pcre \
+ --without-kytea \
+ --without-libstemmer \
+ --with-log-path="${EROOT}var/log/${PN}.log" \
+ --docdir="${EROOT}usr/share/doc/${P}" \
+ --without-ruby \
+ $(use_enable abort) \
+ $(use_enable benchmark) \
+ $(use_enable debug memory-debug) \
+ $(use_enable doc document) \
+ $(use_enable dynamic-malloc-change) \
+ $(use_enable exact-alloc-count) \
+ $(use_enable fmalloc) \
+ $(use_enable futex) \
+ $(use_enable libedit) \
+ $(use_with libevent) \
+ $(use_with lzo) \
+ $(use_with mecab) \
+ $(use_with msgpack message-pack "${EROOT}usr") \
+ $(use_enable nfkc) \
+ $(use_with sphinx sphinx-build) \
+ $(use_enable static-libs static) \
+ $(use_enable uyield) \
+ $(use_enable zeromq) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ dodoc README.md
+
+ use examples || rm -r "${D}usr/share/${PN}" || die
+ # Extra init script
+ rm -r "${D}usr/sbin/groonga-httpd-restart" || die
+}