summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-15 20:34:10 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-15 20:34:10 +0000
commit144af68b3b37cb8a96cac342d709a9a397156cc0 (patch)
treeaf5ba58fe63ce3074d794aff02e998f177b2f5e5 /app-text
parentAdd patch to fix autoconf error. (diff)
downloadgentoo-2-144af68b3b37cb8a96cac342d709a9a397156cc0.tar.gz
gentoo-2-144af68b3b37cb8a96cac342d709a9a397156cc0.tar.bz2
gentoo-2-144af68b3b37cb8a96cac342d709a9a397156cc0.zip
Fix 227297, give repoman a nice cup of "Shut the f*ck up"
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/yamcha/ChangeLog8
-rw-r--r--app-text/yamcha/files/yamcha-0.33-gcc43.patch30
-rw-r--r--app-text/yamcha/yamcha-0.33-r1.ebuild15
3 files changed, 44 insertions, 9 deletions
diff --git a/app-text/yamcha/ChangeLog b/app-text/yamcha/ChangeLog
index ef29caf55459..ec552f1037e3 100644
--- a/app-text/yamcha/ChangeLog
+++ b/app-text/yamcha/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/yamcha
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/ChangeLog,v 1.5 2007/12/25 17:05:39 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/ChangeLog,v 1.6 2008/06/15 20:34:09 loki_val Exp $
+
+ 15 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/yamcha-0.33-gcc43.patch, yamcha-0.33-r1.ebuild:
+ Fix 227297, give repoman a nice cup of "Shut the f*ck up"
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing usata from metadata.xml as per #22931.
diff --git a/app-text/yamcha/files/yamcha-0.33-gcc43.patch b/app-text/yamcha/files/yamcha-0.33-gcc43.patch
new file mode 100644
index 000000000000..c0b3f5273e91
--- /dev/null
+++ b/app-text/yamcha/files/yamcha-0.33-gcc43.patch
@@ -0,0 +1,30 @@
+diff -NrU5 yamcha-0.33.orig/libexec/mkdarts.cpp yamcha-0.33/libexec/mkdarts.cpp
+--- yamcha-0.33.orig/libexec/mkdarts.cpp 2008-06-15 22:22:53.000000000 +0200
++++ yamcha-0.33/libexec/mkdarts.cpp 2008-06-15 22:26:40.000000000 +0200
+@@ -25,10 +25,11 @@
+ #include <cstring>
+ #include <iostream>
+ #include <fstream>
+ #include <string>
+ #include <vector>
++#include <cstdlib>
+ #include "darts.h"
+
+ using namespace std;
+
+ int progress_bar (size_t current, size_t total)
+diff -NrU5 yamcha-0.33.orig/src/param.cpp yamcha-0.33/src/param.cpp
+--- yamcha-0.33.orig/src/param.cpp 2008-06-15 22:22:53.000000000 +0200
++++ yamcha-0.33/src/param.cpp 2008-06-15 22:24:04.000000000 +0200
+@@ -22,10 +22,11 @@
+ */
+
+ #include <fstream>
+ #include <strstream>
+ #include <cstdio>
++#include <cstring>
+ #include "param.h"
+ #include "common.h"
+
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
diff --git a/app-text/yamcha/yamcha-0.33-r1.ebuild b/app-text/yamcha/yamcha-0.33-r1.ebuild
index 659de49339ed..75ad84d86d85 100644
--- a/app-text/yamcha/yamcha-0.33-r1.ebuild
+++ b/app-text/yamcha/yamcha-0.33-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/yamcha-0.33-r1.ebuild,v 1.2 2006/11/02 17:52:04 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/yamcha-0.33-r1.ebuild,v 1.3 2008/06/15 20:34:09 loki_val Exp $
inherit perl-module eutils
# inherit distutils
@@ -22,8 +22,9 @@ DEPEND="sci-misc/tinysvm
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-pm.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-pm.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {
@@ -31,7 +32,7 @@ src_compile() {
emake || die
if use perl ; then
- cd ${S}/perl
+ cd "${S}"/perl
perl-module_src_compile || die
fi
@@ -47,12 +48,12 @@ src_test() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS README
if use perl ; then
- cd ${S}/perl
+ cd "${S}"/perl
perl-module_src_install || die
fi