summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-09-25 19:38:03 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-09-25 19:38:03 +0000
commit117b97f6ab2160887820e7023b5ef436cb4c43c4 (patch)
tree5a837e6b645c94a70e94eb8e5775dca88e785727 /app-text
parentEAPI bump (bug #485990) (diff)
downloadgentoo-2-117b97f6ab2160887820e7023b5ef436cb4c43c4.tar.gz
gentoo-2-117b97f6ab2160887820e7023b5ef436cb4c43c4.tar.bz2
gentoo-2-117b97f6ab2160887820e7023b5ef436cb4c43c4.zip
EAPI bump + prefix support (bug #485986)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/active-dvi/ChangeLog11
-rw-r--r--app-text/active-dvi/active-dvi-1.10.2-r1.ebuild69
2 files changed, 77 insertions, 3 deletions
diff --git a/app-text/active-dvi/ChangeLog b/app-text/active-dvi/ChangeLog
index 060420ff58bc..e8508ca5d439 100644
--- a/app-text/active-dvi/ChangeLog
+++ b/app-text/active-dvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/active-dvi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/ChangeLog,v 1.45 2012/08/07 16:18:16 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/ChangeLog,v 1.46 2013/09/25 19:38:03 ottxor Exp $
+
+*active-dvi-1.10.2-r1 (25 Sep 2013)
+
+ 25 Sep 2013; Christoph Junghans <ottxor@gentoo.org>
+ +active-dvi-1.10.2-r1.ebuild:
+ EAPI bump + prefix support (bug #485986)
07 Aug 2012; Alexis Ballier <aballier@gentoo.org>
-files/active-dvi-1.7.3-asneeded.patch, -active-dvi-1.8.ebuild,
@@ -178,4 +184,3 @@
metadata.xml:
First version of active-dvi in the tree. This has been requested in bug
#22549, and thanks to <mattam@altern.org> for his ebuild submission.
-
diff --git a/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild b/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
new file mode 100644
index 000000000000..68b22369dc68
--- /dev/null
+++ b/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild,v 1.1 2013/09/25 19:38:03 ottxor Exp $
+
+EAPI="5"
+
+inherit eutils autotools texlive-common
+
+MY_PN=${PN/ctive-/}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A DVI previewer and a presenter for slides written in LaTeX"
+SRC_URI="http://gallium.inria.fr/advi/${MY_P}.tar.gz"
+HOMEPAGE="http://gallium.inria.fr/advi/"
+LICENSE="LGPL-2.1"
+
+IUSE="+ocamlopt"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]
+ >=dev-ml/camlimages-4.0.1:=[truetype,tiff,jpeg,postscript,X]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-pstricks
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-latexextra
+ x11-proto/xineramaproto
+ dev-ml/findlib
+ app-text/htmlc
+ dev-tex/hevea"
+
+DOCS=( "README" "TODO" )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.9-htmlcflags.patch"
+ AT_M4DIR="." eautoreconf
+}
+
+src_configure() {
+ TEXMFMAIN="${EPREFIX}"/usr/share/texmf-site econf $(use_enable ocamlopt native-program) \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake
+ cd doc || die
+ VARTEXFONTS="${T}/fonts" emake splash.dvi scratch_write_splash.dvi scratch_draw_splash.dvi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install
+
+ # now install the documentation
+ dodoc ${DOCS}
+
+ export STRIP_MASK="*/bin/advi.byt"
+}
+
+pkg_postinst() {
+ etexmf-update
+}
+
+pkg_postrm() {
+ etexmf-update
+}