summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-05-09 12:36:05 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-05-09 12:36:05 +0000
commit59825903252e2e7bf084cd7854e8b8e2396dcd9d (patch)
tree04f4914df41746090dcdc51e003377c89125053a /app-text/wgetpaste
parentremove perl and python from make.default USE, as on linux (diff)
downloadgentoo-2-59825903252e2e7bf084cd7854e8b8e2396dcd9d.tar.gz
gentoo-2-59825903252e2e7bf084cd7854e8b8e2396dcd9d.tar.bz2
gentoo-2-59825903252e2e7bf084cd7854e8b8e2396dcd9d.zip
Bump to 2.20, bug #415163. Support one more lodgeit-like service.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'app-text/wgetpaste')
-rw-r--r--app-text/wgetpaste/ChangeLog9
-rw-r--r--app-text/wgetpaste/files/wgetpaste-config-default-lodgeit1
-rw-r--r--app-text/wgetpaste/files/wgetpaste-config-lugons5
-rw-r--r--app-text/wgetpaste/metadata.xml3
-rw-r--r--app-text/wgetpaste/wgetpaste-2.20.ebuild30
5 files changed, 47 insertions, 1 deletions
diff --git a/app-text/wgetpaste/ChangeLog b/app-text/wgetpaste/ChangeLog
index b2ca7b4a0ea1..d6a4604addca 100644
--- a/app-text/wgetpaste/ChangeLog
+++ b/app-text/wgetpaste/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/wgetpaste
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wgetpaste/ChangeLog,v 1.121 2012/05/08 14:50:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wgetpaste/ChangeLog,v 1.122 2012/05/09 12:36:04 maksbotan Exp $
+
+*wgetpaste-2.20 (09 May 2012)
+
+ 09 May 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/wgetpaste-config-default-lodgeit, +files/wgetpaste-config-lugons,
+ +wgetpaste-2.20.ebuild, metadata.xml:
+ Bump to 2.20, bug #415163. Support one more lodgeit-like service.
08 May 2012; Agostino Sarubbo <ago@gentoo.org> -wgetpaste-2.17.ebuild,
-wgetpaste-2.18.ebuild:
diff --git a/app-text/wgetpaste/files/wgetpaste-config-default-lodgeit b/app-text/wgetpaste/files/wgetpaste-config-default-lodgeit
new file mode 100644
index 000000000000..c3e8f6a3d8e8
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-config-default-lodgeit
@@ -0,0 +1 @@
+DEFAULT_SERVICE="lugons"
diff --git a/app-text/wgetpaste/files/wgetpaste-config-lugons b/app-text/wgetpaste/files/wgetpaste-config-lugons
new file mode 100644
index 000000000000..d3593d522af7
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-config-lugons
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+SERVICES="${SERVICES} lugons"
+ENGINE_lugons=lodgeit
+URL_lugons="https://paste.lugons.org/"
diff --git a/app-text/wgetpaste/metadata.xml b/app-text/wgetpaste/metadata.xml
index 097cb08fa396..54b88c3fcdf7 100644
--- a/app-text/wgetpaste/metadata.xml
+++ b/app-text/wgetpaste/metadata.xml
@@ -9,4 +9,7 @@
<email>wired@gentoo.org</email>
<name>Alex Alexander</name>
</maintainer>
+ <use>
+ <flag name="lodgeit-default">Set one of lodgeit-like (ex http://paste.pocoo.org) services as default</flag>
+ </use>
</pkgmetadata>
diff --git a/app-text/wgetpaste/wgetpaste-2.20.ebuild b/app-text/wgetpaste/wgetpaste-2.20.ebuild
new file mode 100644
index 000000000000..09cc701f8f25
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.20.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wgetpaste/wgetpaste-2.20.ebuild,v 1.1 2012/05/09 12:36:04 maksbotan Exp $
+
+EAPI="4"
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+SRC_URI="http://wgetpaste.zlin.dk/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="zsh-completion +lodgeit-default"
+
+DEPEND=""
+RDEPEND="net-misc/wget
+ zsh-completion? ( app-shells/zsh )"
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/wgetpaste.d
+ newins "${FILESDIR}"/wgetpaste-config-lugons lugons.conf
+ use lodgeit-default && \
+ newins "${FILESDIR}"/wgetpaste-config-default-lodgeit gentoo-default.conf
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+ fi
+}