summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-03 02:23:43 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-03 02:23:43 +0000
commit4d466755f4cfd51f453e0ef50b25b61f98af32a9 (patch)
treef8e45d6d8e33a74f1c1df85f45a87832518c1d2f /app-text/rman
parentvilistextum 2.6.1 ebuild submitted by coder@descom.com (Ilian Zarov) (diff)
downloadgentoo-2-4d466755f4cfd51f453e0ef50b25b61f98af32a9.tar.gz
gentoo-2-4d466755f4cfd51f453e0ef50b25b61f98af32a9.tar.bz2
gentoo-2-4d466755f4cfd51f453e0ef50b25b61f98af32a9.zip
rman 3.0.9 ebuild submitted by jim@nuttz.org (Jim Nutt)
Diffstat (limited to 'app-text/rman')
-rw-r--r--app-text/rman/files/digest-rman-3.0.91
-rw-r--r--app-text/rman/files/rman-3.0.9-gentoo.diff16
-rw-r--r--app-text/rman/rman-3.0.9.ebuild27
3 files changed, 44 insertions, 0 deletions
diff --git a/app-text/rman/files/digest-rman-3.0.9 b/app-text/rman/files/digest-rman-3.0.9
new file mode 100644
index 000000000000..d6ffa6cf2aa0
--- /dev/null
+++ b/app-text/rman/files/digest-rman-3.0.9
@@ -0,0 +1 @@
+MD5 f29a3bde5b35d1624f41357b96262f8f rman.tar.gz 79222
diff --git a/app-text/rman/files/rman-3.0.9-gentoo.diff b/app-text/rman/files/rman-3.0.9-gentoo.diff
new file mode 100644
index 000000000000..37f3e16d723e
--- /dev/null
+++ b/app-text/rman/files/rman-3.0.9-gentoo.diff
@@ -0,0 +1,16 @@
+--- rman-3.0.9/Makefile Fri Feb 1 17:04:07 2002
++++ rman-3.0.9-gentoo/Makefile Fri Feb 1 17:03:07 2002
+@@ -15,11 +15,8 @@
+ # this must be a directory that's in your bin PATH.
+ # MANDIR holds the man page.
+
+-BINDIR = /usr/local/bin
+-#BINDIR = //C/bin
+-MANDIR = /home/auspex/h/bair/phelps/man/man1
+-#MANDIR = /usr/local/man/man1
+-
++BINDIR = $(DESTDIR)/usr/bin
++MANDIR = $(DESTDIR)/usr/share/man
+
+ ### if you have GNU gcc v2.x, use these definitions
+
diff --git a/app-text/rman/rman-3.0.9.ebuild b/app-text/rman/rman-3.0.9.ebuild
new file mode 100644
index 000000000000..1edb269e1ba7
--- /dev/null
+++ b/app-text/rman/rman-3.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: jim nutt <jim@nuttz.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/rman/rman-3.0.9.ebuild,v 1.1 2002/02/03 02:23:43 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
+A=rman.tar.gz
+SRC_URI="http://polyglotman.sourceforge.net/${A}"
+HOMEPAGE="http://polyglotman.sourceforge.net/"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 <${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -finline-functions" || die
+}
+
+src_install () {
+ dobin ${PN}
+ doman ${PN}.1
+}