summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-10 03:01:33 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-10 03:01:33 +0000
commit96404bbcd8ecab068c996adcf0f1d13514c289e6 (patch)
tree76672c20f5c82e7cbd48f5e569a2e8697f5f613d /app-text/poppler
parentfixed improper pax-marking, and patched build system to keep it from strippin... (diff)
downloadgentoo-2-96404bbcd8ecab068c996adcf0f1d13514c289e6.tar.gz
gentoo-2-96404bbcd8ecab068c996adcf0f1d13514c289e6.tar.bz2
gentoo-2-96404bbcd8ecab068c996adcf0f1d13514c289e6.zip
Masked version bump for testing. Likely still has automagic dep on Qt5.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/ChangeLog8
-rw-r--r--app-text/poppler/poppler-0.24.0.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index ff4d16f1f4b4..578318f7d1d5 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.387 2013/07/12 20:34:24 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.388 2013/08/10 03:01:33 dilfridge Exp $
+
+*poppler-0.24.0 (10 Aug 2013)
+
+ 10 Aug 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +poppler-0.24.0.ebuild:
+ Masked version bump for testing. Likely still has automagic dep on Qt5.
12 Jul 2013; Andreas K. Huettel <dilfridge@gentoo.org>
poppler-0.22.2-r2.ebuild, poppler-0.22.5.ebuild:
diff --git a/app-text/poppler/poppler-0.24.0.ebuild b/app-text/poppler/poppler-0.24.0.ebuild
new file mode 100644
index 000000000000..2e9a2cd71af0
--- /dev/null
+++ b/app-text/poppler/poppler-0.24.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.24.0.ebuild,v 1.1 2013/08/10 03:01:33 dilfridge Exp $
+
+EAPI=5
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0/43"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg jpeg2k +lcms png qt4 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-1.32.1 )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/openjpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ png? ( media-libs/libpng:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( >=app-text/poppler-data-0.4.4 )
+"
+
+DOCS=(AUTHORS NEWS README README-XPDF TODO)
+
+src_configure() {
+ # this is needed for multilib, see bug 459394
+ local ft_libdir ft_includedir
+ ft_libdir="$($(tc-getPKG_CONFIG) freetype2 --variable=libdir)"
+ ft_includedir="$($(tc-getPKG_CONFIG) freetype2 --variable=includedir)"
+ export FREETYPE_DIR="${ft_libdir}:${ft_includedir%/include}"
+ einfo "Detected FreeType at ${FREETYPE_DIR}"
+
+ mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_XPDF_HEADERS=ON
+ $(cmake-utils_use_enable curl LIBCURL)
+ $(cmake-utils_use_enable cxx CPP)
+ $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with introspection GObjectIntrospection)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ -DWITH_QT5=OFF # this probably does not work yet
+ $(cmake-utils_use_with tiff)
+ )
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use cairo && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}