summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-12 14:30:19 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-12 14:30:19 +0000
commit3e0d1ba0765fbcde80beba1854c949922b5a8274 (patch)
tree603548ebf0d5c07f759ee7ebcc96759a71e49866 /app-text/mupdf
parentMigrate to EAPI 5. Add missing dependency. Slight improvement to included .de... (diff)
downloadgentoo-2-3e0d1ba0765fbcde80beba1854c949922b5a8274.tar.gz
gentoo-2-3e0d1ba0765fbcde80beba1854c949922b5a8274.tar.bz2
gentoo-2-3e0d1ba0765fbcde80beba1854c949922b5a8274.zip
Fix library linking
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-text/mupdf')
-rw-r--r--app-text/mupdf/ChangeLog6
-rw-r--r--app-text/mupdf/mupdf-1.2.ebuild4
-rw-r--r--app-text/mupdf/mupdf-9999.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index a297b76ac4e0..e339b3796584 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.75 2013/06/11 08:57:43 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.76 2013/06/12 14:30:19 xmw Exp $
+
+ 12 Jun 2013; Michael Weber <xmw@gentoo.org> mupdf-1.2.ebuild,
+ mupdf-9999.ebuild:
+ Fix library linking
11 Jun 2013; Michael Weber <xmw@gentoo.org>
+files/mupdf-9999-pkg-config.patch, files/mupdf-1.2-pkg-config.patch,
diff --git a/app-text/mupdf/mupdf-1.2.ebuild b/app-text/mupdf/mupdf-1.2.ebuild
index 210a101f087a..e344cb93c871 100644
--- a/app-text/mupdf/mupdf-1.2.ebuild
+++ b/app-text/mupdf/mupdf-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-1.2.ebuild,v 1.8 2013/06/11 08:57:43 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-1.2.ebuild,v 1.9 2013/06/12 14:30:19 xmw Exp $
EAPI=5
@@ -76,7 +76,7 @@ src_prepare() {
my_soname=libfitz.so.1.2
sed -e "\$a\$(FITZ_LIB):" \
- -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -o \$@ \$^" \
+ -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -Wl,--no-undefined -o \$@ \$^ \$(LIBS)" \
-e "/^FITZ_LIB :=/s:=.*:= build/debug/${my_soname}:" \
-i Makefile || die
}
diff --git a/app-text/mupdf/mupdf-9999.ebuild b/app-text/mupdf/mupdf-9999.ebuild
index b8aa9b5b97b3..6539509801e2 100644
--- a/app-text/mupdf/mupdf-9999.ebuild
+++ b/app-text/mupdf/mupdf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.33 2013/06/11 08:57:43 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.34 2013/06/12 14:30:19 xmw Exp $
EAPI=5
@@ -78,7 +78,7 @@ src_prepare() {
my_soname=libfitz.so.1.2
sed -e "\$a\$(FITZ_LIB):" \
- -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -o \$@ \$^" \
+ -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -Wl,--no-undefined -o \$@ \$^ \$(LIBS)" \
-e "/^FITZ_LIB :=/s:=.*:= build/debug/${my_soname}:" \
-i Makefile || die
}