summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-25 07:56:32 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-25 07:56:32 +0000
commit1496621eab3607d408d0b32210f66b5cd760c4bf (patch)
tree09c78da2837b4f99c002313330475f4412e35cb3 /app-text/libwpd
parentBump to vala-0.18 stable; drop pre-releases. (diff)
downloadgentoo-2-1496621eab3607d408d0b32210f66b5cd760c4bf.tar.gz
gentoo-2-1496621eab3607d408d0b32210f66b5cd760c4bf.tar.bz2
gentoo-2-1496621eab3607d408d0b32210f66b5cd760c4bf.zip
Version bump to latest libwpd.
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'app-text/libwpd')
-rw-r--r--app-text/libwpd/ChangeLog7
-rw-r--r--app-text/libwpd/libwpd-0.9.6.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-text/libwpd/ChangeLog b/app-text/libwpd/ChangeLog
index 1b4443440039..d5a7c57a7046 100644
--- a/app-text/libwpd/ChangeLog
+++ b/app-text/libwpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libwpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.100 2012/05/29 22:04:46 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.101 2012/09/25 07:56:32 scarabeus Exp $
+
+*libwpd-0.9.6 (25 Sep 2012)
+
+ 25 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +libwpd-0.9.6.ebuild:
+ Version bump to latest libwpd.
29 May 2012; Anthony G. Basile <blueness@gentoo.org> libwpd-0.9.4.ebuild:
Keyword ~mips
diff --git a/app-text/libwpd/libwpd-0.9.6.ebuild b/app-text/libwpd/libwpd-0.9.6.ebuild
new file mode 100644
index 000000000000..a6427605cc61
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.9.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/libwpd-0.9.6.ebuild,v 1.1 2012/09/25 07:56:32 scarabeus Exp $
+
+EAPI=4
+
+inherit alternatives autotools eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test +tools"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}
+ !<app-text/libwpd-0.8.14-r1"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_with tools stream) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9]"
+ fi
+}