summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-03-25 22:13:52 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-03-25 22:13:52 +0000
commit9e413e3eeb34d1159d99985b8e235e4595356bb0 (patch)
tree1359ae4af0102102131fada28a32716d08e839b7 /app-text/glark/glark-1.8.0.ebuild
parentStable on x86, bug #172025. (diff)
downloadgentoo-2-9e413e3eeb34d1159d99985b8e235e4595356bb0.tar.gz
gentoo-2-9e413e3eeb34d1159d99985b8e235e4595356bb0.tar.bz2
gentoo-2-9e413e3eeb34d1159d99985b8e235e4595356bb0.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-text/glark/glark-1.8.0.ebuild')
-rw-r--r--app-text/glark/glark-1.8.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/glark/glark-1.8.0.ebuild b/app-text/glark/glark-1.8.0.ebuild
new file mode 100644
index 000000000000..1706a6cb076c
--- /dev/null
+++ b/app-text/glark/glark-1.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.8.0.ebuild,v 1.1 2007/03/25 22:13:52 dirtyepic Exp $
+
+inherit bash-completion
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="http://www.incava.org/projects/glark/"
+SRC_URI="http://www.incava.org/pub/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc-macos ~sparc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+# perl dep is for pod2man
+DEPEND="virtual/ruby
+ dev-lang/perl"
+RDEPEND="virtual/ruby"
+
+src_compile() {
+ emake
+ # force the manpage to be rebuilt
+ rm ${PN}.1
+ make ${PN}.1
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dobashcompletion "${FILESDIR}"/1.8.0/glark-completion ${PN}
+}