summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-05 00:29:57 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-05 00:29:57 +0000
commitb2a62af2d13c9525cf78fa8b4bb86c9f39bd8b29 (patch)
treeaee115cd4e8cbf2cfdc660c400f59444dd35cd38 /app-text/evince
parentversion bump and clean up. Bug #414283 (diff)
downloadgentoo-2-b2a62af2d13c9525cf78fa8b4bb86c9f39bd8b29.tar.gz
gentoo-2-b2a62af2d13c9525cf78fa8b4bb86c9f39bd8b29.tar.bz2
gentoo-2-b2a62af2d13c9525cf78fa8b4bb86c9f39bd8b29.zip
Version bump with small bugfixes and UI improvements.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog8
-rw-r--r--app-text/evince/evince-3.4.0.ebuild113
-rw-r--r--app-text/evince/files/evince-3.4.0-glib-gold.patch54
3 files changed, 174 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index eabdf38bb9e3..aa9a95258565 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/evince
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.243 2012/05/04 03:33:15 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.244 2012/05/05 00:29:57 tetromino Exp $
+
+*evince-3.4.0 (05 May 2012)
+
+ 05 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +evince-3.4.0.ebuild, +files/evince-3.4.0-glib-gold.patch:
+ Version bump with small bugfixes and UI improvements.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> evince-2.32.0-r3.ebuild,
evince-2.32.0-r4.ebuild, evince-3.2.1.ebuild, evince-3.2.1-r1.ebuild:
diff --git a/app-text/evince/evince-3.4.0.ebuild b/app-text/evince/evince-3.4.0.ebuild
new file mode 100644
index 000000000000..0aa54857032e
--- /dev/null
+++ b/app-text/evince/evince-3.4.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.4.0.ebuild,v 1.1 2012/05/05 00:29:57 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dbus debug djvu doc dvi gnome-keyring +introspection nautilus t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+
+# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
+# not mature enough
+# atk used in libview
+# gdk-pixbuf used all over the place
+# libX11 used for totem-screensaver
+RDEPEND="
+ >=app-text/libspectre-0.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.25.11:2
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.0.2:3[introspection?]
+ x11-libs/libX11
+ >=x11-libs/libSM-1
+ x11-libs/libICE
+ gnome-base/gsettings-desktop-schemas
+ || (
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+ >=x11-libs/cairo-1.10.0
+ >=app-text/poppler-0.18[cairo]
+ djvu? ( >=app-text/djvu-3.5.17 )
+ dvi? (
+ virtual/tex-base
+ dev-libs/kpathsea
+ t1lib? ( >=media-libs/t1lib-5.0.0 ) )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22.0 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6 )
+ nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
+ tiff? ( >=media-libs/tiff-3.6:0 )
+ xps? ( >=app-text/libgxps-0.2.1 )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/docbook-xml-dtd:4.3
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.13
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+ELTCONF="--portage"
+
+# Needs dogtail and pyspi from http://fedorahosted.org/dogtail/
+# Releases: http://people.redhat.com/zcerza/dogtail/releases/
+RESTRICT="test"
+
+pkg_setup() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of Gnome apps that doesn't require network for that.
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --disable-tests
+ --enable-pdf
+ --enable-comics
+ --enable-thumbnailer
+ --with-smclient=xsmp
+ --with-platform=gnome
+ --enable-help
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with gnome-keyring keyring)
+ $(use_enable introspection)
+ $(use_enable nautilus)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ $(use_enable xps)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ # Regenerate marshalers to allow building with <glib-2.32
+ rm -v cut-n-paste/gimpcellrenderertoggle/gimpwidgetsmarshal.{c,h} \
+ cut-n-paste/toolbar-editor/eggmarshalers.{c,h} \
+ libview/ev-view-marshal.{c,h} || die "rm failed"
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+
+ # glib-2.32 restructured dep libs in pkg-config files, #414065
+ epatch "${FILESDIR}/${P}-glib-gold.patch"
+
+ gnome2_src_prepare
+
+ AT_NOELIBTOOLIZE=yes eautoreconf
+
+ # Do not depend on gnome-icon-theme, bug #326855, #391859
+ sed -e 's/gnome-icon-theme >= $GNOME_ICON_THEME_REQUIRED//g' \
+ -i configure || die "sed failed"
+}
diff --git a/app-text/evince/files/evince-3.4.0-glib-gold.patch b/app-text/evince/files/evince-3.4.0-glib-gold.patch
new file mode 100644
index 000000000000..34733f75908b
--- /dev/null
+++ b/app-text/evince/files/evince-3.4.0-glib-gold.patch
@@ -0,0 +1,54 @@
+From f2f9097ea87e2f0d15241ac0ee95099a219b7539 Mon Sep 17 00:00:00 2001
+From: Justin Lecher <jlec@gentoo.org>
+Date: Mon, 30 Apr 2012 11:51:18 +0200
+Subject: [PATCH] Fix underlinking with >=glib-2.32 detected by gold linker
+
+As descripted in bug 675129, recent changes in pkg-config files
+drop necessary libs from linking, more accurate gio-2.0 droppes
+gmodule-no-export-2.0.
+
+Readd gmodule-no-export-2.0 at all necessary places.
+
+Signed-off-by: Justin Lecher <jlec@gentoo.org>
+---
+ configure.ac | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 66958fa..2ef6e50 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -154,10 +154,10 @@ fi
+ ZLIB_LIBS=-lz
+ AC_SUBST(ZLIB_LIBS)
+
+-PKG_CHECK_MODULES(LIBDOCUMENT, gtk+-3.0 >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gmodule-2.0)
++PKG_CHECK_MODULES(LIBDOCUMENT, gtk+-3.0 >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gmodule-no-export-2.0 >= $GLIB_REQUIRED gmodule-2.0)
+ PKG_CHECK_MODULES(LIBVIEW, gtk+-3.0 >= $GTK_REQUIRED gail-3.0 >= $GTK_REQUIRED gthread-2.0 gio-2.0 >= $GLIB_REQUIRED)
+ PKG_CHECK_MODULES(BACKEND, cairo >= $CAIRO_REQUIRED gtk+-3.0 >= $GTK_REQUIRED)
+-PKG_CHECK_MODULES(FRONTEND_CORE, gtk+-3.0 >= $GTK_REQUIRED gthread-2.0 gio-2.0 >= $GLIB_REQUIRED)
++PKG_CHECK_MODULES(FRONTEND_CORE, gtk+-3.0 >= $GTK_REQUIRED gthread-2.0 gio-2.0 >= $GLIB_REQUIRED gmodule-no-export-2.0 >= $GLIB_REQUIRED)
+
+ SHELL_PLATFORM_PKGS=
+ case "$with_platform" in
+@@ -180,7 +180,7 @@ case "$with_platform" in
+ ;;
+ esac
+
+-PKG_CHECK_MODULES([SHELL_CORE],[libxml-2.0 >= $LIBXML_REQUIRED gtk+-3.0 >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS])
++PKG_CHECK_MODULES([SHELL_CORE],[libxml-2.0 >= $LIBXML_REQUIRED gtk+-3.0 >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gmodule-no-export-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS])
+
+ # *********
+ # SM client
+@@ -407,7 +407,7 @@ AC_ARG_ENABLE([previewer],
+ [enable_previewer=yes])
+
+ if test x$enable_previewer = "xyes" ; then
+- PKG_CHECK_MODULES([PREVIEWER],[gtk+-3.0 >= $GTK_REQUIRED gthread-2.0 gio-2.0 >= $GLIB_REQUIRED])
++ PKG_CHECK_MODULES([PREVIEWER],[gtk+-3.0 >= $GTK_REQUIRED gthread-2.0 gio-2.0 >= $GLIB_REQUIRED gmodule-no-export-2.0 >= $GLIB_REQUIRED])
+ fi
+
+ AM_CONDITIONAL([ENABLE_PREVIEWER],[test "$enable_previewer" = "yes"])
+--
+1.7.8.6
+