summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2014-11-09 13:18:44 +0000
committerBen de Groot <yngwin@gentoo.org>2014-11-09 13:18:44 +0000
commit5a3d22c3df3bfcff50a774f72cc3194d84764caf (patch)
treea36301b758231ff9b2fab564182abe702d106f36 /app-text/calibre
parentVersion bump (diff)
downloadgentoo-2-5a3d22c3df3bfcff50a774f72cc3194d84764caf.tar.gz
gentoo-2-5a3d22c3df3bfcff50a774f72cc3194d84764caf.tar.bz2
gentoo-2-5a3d22c3df3bfcff50a774f72cc3194d84764caf.zip
Fix failure of xdg tools to recognize vendor prefix (see bug #521484)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x0F9C590B7FF324F6!)
Diffstat (limited to 'app-text/calibre')
-rw-r--r--app-text/calibre/ChangeLog5
-rw-r--r--app-text/calibre/calibre-2.9.0.ebuild12
2 files changed, 13 insertions, 4 deletions
diff --git a/app-text/calibre/ChangeLog b/app-text/calibre/ChangeLog
index daaa8eae781c..9623426d7177 100644
--- a/app-text/calibre/ChangeLog
+++ b/app-text/calibre/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/calibre
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.334 2014/11/09 12:28:05 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.335 2014/11/09 13:18:44 yngwin Exp $
+
+ 09 Nov 2014; Ben de Groot <yngwin@gentoo.org> calibre-2.9.0.ebuild:
+ Fix failure of xdg tools to recognize vendor prefix (see bug #521484)
*calibre-2.9.0 (09 Nov 2014)
diff --git a/app-text/calibre/calibre-2.9.0.ebuild b/app-text/calibre/calibre-2.9.0.ebuild
index 7e28678701e3..d4fb8991fb5a 100644
--- a/app-text/calibre/calibre-2.9.0.ebuild
+++ b/app-text/calibre/calibre-2.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/calibre-2.9.0.ebuild,v 1.1 2014/11/09 12:28:05 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/calibre-2.9.0.ebuild,v 1.2 2014/11/09 13:18:44 yngwin Exp $
EAPI=5
@@ -111,14 +111,20 @@ src_prepare() {
-i setup/extensions.py || die "sed failed to patch extensions.py"
# use system beautifulsoup, instead of bundled
- rm -f "${S}"/src/calibre/ebooks/BeautifulSoup.py || die "could not remove bundled beautifulsoup"
+ rm -f "${S}"/src/calibre/ebooks/BeautifulSoup.py \
+ || die "could not remove bundled beautifulsoup"
find "${S}" -type f -name \*.py -exec \
sed -e 's/calibre.ebooks.BeautifulSoup/BeautifulSoup/' -i {} + \
|| die "could not sed bundled beautifulsoup out of the source tree"
+ # avoid failure of xdg tools to recognize vendor prefix
+ sed -e "s|xdg-icon-resource install|xdg-icon-resource install --novendor|" \
+ -e "s|'xdg-mime', 'install'|'xdg-mime', 'install', '--novendor'|" \
+ -e "s|'xdg-desktop-menu', 'install'|'xdg-desktop-menu', 'install', '--novendor'|" \
+ -i "${S}"/src/calibre/linux.py || die 'sed failed'
+
# no_updates: do not annoy user with "new version is availible all the time
# disable_plugins: walking sec-hole, wait for upstream to use GHNS interface
- # C locale: if LC_ALL=C do not raise an exception when locale cannot be canonicalized
epatch \
"${FILESDIR}/${PN}-2.9.0-no_updates_dialog.patch" \
"${FILESDIR}/${PN}-disable_plugins.patch"