summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2005-11-30 00:02:08 +0000
committerJeroen Roovers <jer@gentoo.org>2005-11-30 00:02:08 +0000
commit9ff39d41b1f81499804a7affd94f3cfc3d6c4833 (patch)
treecdbec0a5e3a399c3f00f3b2d5b1cad2fe0188337 /app-text/an
parentCleanup of old versions. (diff)
downloadgentoo-2-9ff39d41b1f81499804a7affd94f3cfc3d6c4833.tar.gz
gentoo-2-9ff39d41b1f81499804a7affd94f3cfc3d6c4833.tar.bz2
gentoo-2-9ff39d41b1f81499804a7affd94f3cfc3d6c4833.zip
Import of Debian's improved an.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-text/an')
-rw-r--r--app-text/an/ChangeLog10
-rw-r--r--app-text/an/Manifest3
-rw-r--r--app-text/an/an-0.95.3.ebuild75
-rw-r--r--app-text/an/files/an_0.95-3.diff.gzbin0 -> 3274 bytes
-rw-r--r--app-text/an/files/digest-an-0.95.31
5 files changed, 88 insertions, 1 deletions
diff --git a/app-text/an/ChangeLog b/app-text/an/ChangeLog
index f197c4777608..8fa9cf629726 100644
--- a/app-text/an/ChangeLog
+++ b/app-text/an/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/an
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.4 2005/11/22 14:49:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.5 2005/11/30 00:02:08 jer Exp $
+
+*an-0.95.3 (29 Nov 2005)
+
+ 29 Nov 2005; Jeroen Roovers <jer@gentoo.org> +files/an_0.95-3.diff.gz,
+ +an-0.95.3.ebuild:
+ Import from Debian's improved an[1].
+
+ [1] http://lists.debian.org/debian-devel/2000/11/msg00319.html
22 Nov 2005; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Reassigning to no-herd
diff --git a/app-text/an/Manifest b/app-text/an/Manifest
index 1080d7e3c367..aca29c5f3cb7 100644
--- a/app-text/an/Manifest
+++ b/app-text/an/Manifest
@@ -1,4 +1,7 @@
MD5 775f638df6865b0ca6375871cf5bf7d1 ChangeLog 605
MD5 8104ae0d178b6caec902262cb593d1a2 an-0.93.ebuild 1742
+MD5 84baa1718cfdc54d2e67a20e4bd4f772 an-0.95.3.ebuild 2035
+MD5 3c78113d8bab704b1a33eeaf444ae045 files/an_0.95-3.diff.gz 3274
MD5 bfeba1bf1787a51a47d7d36fee06a4a6 files/digest-an-0.93 58
+MD5 0ae7dd4d477690add5b47402eb50b946 files/digest-an-0.95.3 63
MD5 3c2afaa2ec4bbe2e6a014f61423fd746 metadata.xml 360
diff --git a/app-text/an/an-0.95.3.ebuild b/app-text/an/an-0.95.3.ebuild
new file mode 100644
index 000000000000..fe7ad702b080
--- /dev/null
+++ b/app-text/an/an-0.95.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.95.3.ebuild,v 1.1 2005/11/30 00:02:08 jer Exp $
+
+DESCRIPTION="Very fast anagram generator with dictionary lookup"
+HOMEPAGE="http://packages.debian.org/stable/games/an"
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+SRC_URI="http://ftp.debian.org/debian/pool/main/a/an/${PN}_${MY_PV}.orig.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~hppa ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/miscfiles"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Patching to -r3:
+ MY_PL="$(replace_version_separator 2 -)"
+ epatch "${FILESDIR}"/${PN}_${MY_PL}.diff.gz
+
+ ebegin "Patching an to use toolchain and custom CFLAGS"
+ sed -e "s:gcc:$(tc-getCC):" \
+ -e "s:-O2.*:${CFLAGS}:" \
+ -i Makefile lib/Makefile
+ eend ${?}
+
+ # sys-apps/miscfiles doesn't have /usr/dict/words:
+ sed \
+ -e 's:/usr/dict/words:/usr/share/dict/words:' \
+ -i README || die
+}
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.6 || die
+ dodoc \
+ debian/changelog \
+ debian/README.Debian \
+ DICTIONARY \
+ EXAMPLE.ANAGRAMS \
+ HINTS \
+ INSTALL \
+ README \
+ TODO || die
+}
+
+pkg_postinst() {
+ ewarn "If you merged sys-apps/miscfiles with USE=minimal,"
+ ewarn "an will NOT work properly, as /usr/share/dict/words"
+ ewarn "will then be a symlink to a gzipped file. an currently"
+ ewarn "does not support gzipped dictionary files and will"
+ ewarn "only produce garbage."
+ ewarn "Do 'USE=-minimal emerge sys-apps/miscfiles', or run an"
+ ewarn "with the -d /path/to/dictionary option, perhaps using"
+ ewarn "one of the files mentioned below."
+ echo
+
+ einfo "Helpful note from an's author:"
+ einfo " If you do not have a dictionary you can obtain one from the"
+ einfo " following site: ftp://ftp.funet.fi/pub/doc/dictionaries/"
+ einfo " You will find a selection of dictionaries in many different"
+ einfo " languages here."
+}
diff --git a/app-text/an/files/an_0.95-3.diff.gz b/app-text/an/files/an_0.95-3.diff.gz
new file mode 100644
index 000000000000..e9ae322c91e7
--- /dev/null
+++ b/app-text/an/files/an_0.95-3.diff.gz
Binary files differ
diff --git a/app-text/an/files/digest-an-0.95.3 b/app-text/an/files/digest-an-0.95.3
new file mode 100644
index 000000000000..2f47e578647f
--- /dev/null
+++ b/app-text/an/files/digest-an-0.95.3
@@ -0,0 +1 @@
+MD5 1f67775dd505a4bad7f891d6062da560 an_0.95.orig.tar.gz 47829