summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-11-12 18:43:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-11-12 18:43:21 +0000
commitf3cdd4fb9f4a9b02fe25b82dae6c7a08068bbb9f (patch)
tree7a5037129ee5394546f62472257c895de99f2a83 /app-text/active-dvi
parentRemoved old (diff)
downloadgentoo-2-f3cdd4fb9f4a9b02fe25b82dae6c7a08068bbb9f.tar.gz
gentoo-2-f3cdd4fb9f4a9b02fe25b82dae6c7a08068bbb9f.tar.bz2
gentoo-2-f3cdd4fb9f4a9b02fe25b82dae6c7a08068bbb9f.zip
version bump
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'app-text/active-dvi')
-rw-r--r--app-text/active-dvi/ChangeLog7
-rw-r--r--app-text/active-dvi/active-dvi-1.8.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/app-text/active-dvi/ChangeLog b/app-text/active-dvi/ChangeLog
index 21153141e373..51b8acb576b4 100644
--- a/app-text/active-dvi/ChangeLog
+++ b/app-text/active-dvi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/active-dvi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/ChangeLog,v 1.31 2009/08/04 07:34:54 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/ChangeLog,v 1.32 2009/11/12 18:43:21 aballier Exp $
+
+*active-dvi-1.8 (12 Nov 2009)
+
+ 12 Nov 2009; Alexis Ballier <aballier@gentoo.org> +active-dvi-1.8.ebuild:
+ version bump
04 Aug 2009; Alexis Ballier <aballier@gentoo.org>
-active-dvi-1.7.3.ebuild:
diff --git a/app-text/active-dvi/active-dvi-1.8.ebuild b/app-text/active-dvi/active-dvi-1.8.ebuild
new file mode 100644
index 000000000000..077722790ec7
--- /dev/null
+++ b/app-text/active-dvi/active-dvi-1.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/active-dvi-1.8.ebuild,v 1.1 2009/11/12 18:43:21 aballier Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+MY_PN=${PN/ctive-/}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A DVI previewer and a presenter for slides written in LaTeX"
+SRC_URI="http://pauillac.inria.fr/advi/${MY_P}.tar.gz"
+HOMEPAGE="http://pauillac.inria.fr/advi/"
+LICENSE="LGPL-2.1"
+
+IUSE="+ocamlopt tk"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/ocaml-3.10.0[ocamlopt?,tk?]
+ >=dev-ml/camlimages-3.0.1[truetype,tiff,jpeg,gs]
+ virtual/latex-base
+ virtual/ghostscript
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ || ( ( dev-texlive/texlive-pstricks dev-texlive/texlive-pictures )
+ app-text/ptex )
+ x11-proto/xineramaproto
+ dev-ml/findlib
+ dev-tex/hevea"
+
+DOCS="README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.7.3-asneeded.patch"
+ AT_M4DIR="." eautoreconf
+}
+
+src_configure() {
+ export ADVI_LOC="/usr/share/texmf/tex/latex/advi"
+ econf $(use_enable ocamlopt native-program)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ cd doc
+ VARTEXFONTS="${T}/fonts" emake splash.dvi scratch_write_splash.dvi scratch_draw_splash.dvi || die "failed to create documentation"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install || die
+
+ # now install the documentation
+ dodoc ${DOCS}
+ cd "${S}"/doc
+
+ insinto /usr/share/texmf/tex/latex/advi
+ doins splash.dvi scratch_write_splash.dvi scratch_draw_splash.dvi || die "failed to install splashes"
+ export STRIP_MASK="*/bin/advi.byt"
+}
+
+pkg_postinst() {
+ einfo "Running texhash to complete installation.."
+ texhash
+}
+
+pkg_postrm() {
+ einfo "Running texhash to complete installation.."
+ texhash
+}