summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-02 13:02:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-02 13:02:16 +0000
commitb960d798328ca9918696034381a53eb838a929b9 (patch)
treeeae22f69dc9bfbbab3b27505fa3cf21a3d44f794 /app-shells
parentNew license for app-shells/rc. (diff)
downloadgentoo-2-b960d798328ca9918696034381a53eb838a929b9.tar.gz
gentoo-2-b960d798328ca9918696034381a53eb838a929b9.tar.bz2
gentoo-2-b960d798328ca9918696034381a53eb838a929b9.zip
Version bump.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rc/ChangeLog7
-rw-r--r--app-shells/rc/rc-1.7.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-shells/rc/ChangeLog b/app-shells/rc/ChangeLog
index 0ab3ec8c8ee1..903d46d3dcba 100644
--- a/app-shells/rc/ChangeLog
+++ b/app-shells/rc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/rc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/rc/ChangeLog,v 1.1 2009/10/02 12:41:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rc/ChangeLog,v 1.2 2009/10/02 13:02:16 ssuominen Exp $
+
+*rc-1.7.2 (02 Oct 2009)
+
+ 02 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> +rc-1.7.2.ebuild:
+ Version bump.
*rc-1.7.1 (02 Oct 2009)
diff --git a/app-shells/rc/rc-1.7.2.ebuild b/app-shells/rc/rc-1.7.2.ebuild
new file mode 100644
index 000000000000..c28de4afaf0f
--- /dev/null
+++ b/app-shells/rc/rc-1.7.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rc/rc-1.7.2.ebuild,v 1.1 2009/10/02 13:02:16 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://rc-shell.slackmatic.org/"
+SRC_URI="ftp://rc.quanstro.net/pub/${P}.tbz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-readline"
+ use libedit && myconf="--with-editline"
+
+ econf \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ into /
+ newbin rc rcsh || die
+ newman rc.1 rcsh.1
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/rcsh$" "${ROOT}"etc/shells; echo "/bin/rcsh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}