summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-07-13 09:28:58 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-07-13 09:28:58 +0000
commit667a627e153c5e469fec3772e304ccf10ca28af6 (patch)
treeba9c728960c30a2f6f628dde9f4fc4c84e9ba641 /app-shells
parentRevert style change w/find+sed as the indented flags are for sed, not find #5... (diff)
downloadgentoo-2-667a627e153c5e469fec3772e304ccf10ca28af6.tar.gz
gentoo-2-667a627e153c5e469fec3772e304ccf10ca28af6.tar.bz2
gentoo-2-667a627e153c5e469fec3772e304ccf10ca28af6.zip
Version bump (bug #554684)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 981CA6FC)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/ChangeLog7
-rw-r--r--app-shells/fish/fish-2.2.0.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index 06d3b5f33f1b..b458eb04f012 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.75 2015/03/21 11:10:33 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.76 2015/07/13 09:28:58 polynomial-c Exp $
+
+*fish-2.2.0 (13 Jul 2015)
+
+ 13 Jul 2015; Lars Wendler <polynomial-c@gentoo.org> +fish-2.2.0.ebuild:
+ Version bump (bug #554684).
*fish-2.1.2 (21 Mar 2015)
diff --git a/app-shells/fish/fish-2.2.0.ebuild b/app-shells/fish/fish-2.2.0.ebuild
new file mode 100644
index 000000000000..a5eb2476cdc1
--- /dev/null
+++ b/app-shells/fish/fish-2.2.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-2.2.0.ebuild,v 1.1 2015/07/13 09:28:58 polynomial-c Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit base
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bc
+ sys-devel/gettext
+ X? ( x11-misc/xsel )"
+
+# fish can add man-page completions from lzma and xz compressed man pages
+# through a python script. That's why we depend on python here (bug #490478)
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin
+}
+
+src_test() {
+ if has_version ~${CATEGORY}/${P} ; then
+ emake test
+ else
+ ewarn "The test suite only works when the package is already installed"
+ fi
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "To use fish as your login shell:"
+ elog "* add the line '${EPREFIX}/bin/${PN}'"
+ elog "* to the file '${EPREFIX}/etc/shells'."
+ elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
+ elog "browser of your choice to get acces to ${PN}'s help system:"
+ elog " BROWSER=\"/usr/bin/firefox\""
+ elog
+ elog "In order to get lzma and xz support for man-page completion please"
+ elog "emerge one of the following packages:"
+ elog " dev-python/backports-lzma"
+ elog " >=dev-lang/python-3.3"
+ elog
+ elog "Have fun!"
+}