summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-10-09 15:18:10 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-10-09 15:18:10 +0000
commit4e577e198bc51e569bee0783d3f5c46a4cece52a (patch)
tree9f77861315274ce3fb98fd0cd4d86d7b21087921 /app-shells
parentMarking sparc, amd64 stable; cleaning out stale ebuilds (diff)
downloadgentoo-2-4e577e198bc51e569bee0783d3f5c46a4cece52a.tar.gz
gentoo-2-4e577e198bc51e569bee0783d3f5c46a4cece52a.tar.bz2
gentoo-2-4e577e198bc51e569bee0783d3f5c46a4cece52a.zip
Fix pattern matching with a non-matching character class by
askwar@digitalprojects.com, bug #150030. (Portage version: 2.1.2_pre2-r7)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog9
-rw-r--r--app-shells/dash/dash-0.5.3.3-r1.ebuild46
-rw-r--r--app-shells/dash/files/dash-0.5.3.3-non-matching-charclass.patch11
-rw-r--r--app-shells/dash/files/digest-dash-0.5.3.3-r16
-rw-r--r--app-shells/dash/metadata.xml4
5 files changed, 75 insertions, 1 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 8f0a8c154457..8aa31e9d2f2b 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.33 2006/07/06 22:57:35 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.34 2006/10/09 15:18:10 exg Exp $
+
+*dash-0.5.3.3-r1 (09 Oct 2006)
+
+ 09 Oct 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/dash-0.5.3.3-non-matching-charclass.patch, +dash-0.5.3.3-r1.ebuild:
+ Fix pattern matching with a non-matching character class by
+ askwar@digitalprojects.com, bug #150030.
06 Jul 2006; Jon Hood <squinky86@gentoo.org> dash-0.5.3.3.ebuild:
Mark ~amd64 wrt bug #139441.
diff --git a/app-shells/dash/dash-0.5.3.3-r1.ebuild b/app-shells/dash/dash-0.5.3.3-r1.ebuild
new file mode 100644
index 000000000000..e9178529b104
--- /dev/null
+++ b/app-shells/dash/dash-0.5.3.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.3-r1.ebuild,v 1.1 2006/10/09 15:18:10 exg Exp $
+
+inherit eutils versionator flag-o-matic toolchain-funcs
+
+DEB_P="${PN}_$(replace_version_separator 3 '-')"
+MY_P2="${DEB_P%-*}"
+MY_P="${MY_P2/_/-}"
+
+DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
+SRC_URI="mirror://debian/pool/main/d/dash/${MY_P2}.orig.tar.gz \
+ mirror://debian/pool/main/d/dash/${DEB_P}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND=""
+DEPEND="sys-devel/bison"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${DEB_P}.diff
+ epatch "${FILESDIR}"/${P}-non-matching-charclass.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ export CC="$(tc-getCC)"
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ exeinto /bin
+ newexe src/dash dash
+ newman src/dash.1 dash.1
+ dodoc COPYING ChangeLog
+}
diff --git a/app-shells/dash/files/dash-0.5.3.3-non-matching-charclass.patch b/app-shells/dash/files/dash-0.5.3.3-non-matching-charclass.patch
new file mode 100644
index 000000000000..3af461aeb68f
--- /dev/null
+++ b/app-shells/dash/files/dash-0.5.3.3-non-matching-charclass.patch
@@ -0,0 +1,11 @@
+--- dash-0.5.3.orig/src/expand.c 2005-11-26 04:17:55.000000000 +0100
++++ dash-0.5.3/src/expand.c 2006-10-04 10:02:08.186753039 +0200
+@@ -1581,7 +1581,7 @@
+ if (c == '[') {
+ const char *r;
+
+- found |= ccmatch(p, chr, &r);
++ found |= !!ccmatch(p, chr, &r);
+ if (r) {
+ p = r;
+ continue;
diff --git a/app-shells/dash/files/digest-dash-0.5.3.3-r1 b/app-shells/dash/files/digest-dash-0.5.3.3-r1
new file mode 100644
index 000000000000..3a812e7045c6
--- /dev/null
+++ b/app-shells/dash/files/digest-dash-0.5.3.3-r1
@@ -0,0 +1,6 @@
+MD5 d90f816432ab5055f37abf0441018bf6 dash_0.5.3-3.diff.gz 26636
+RMD160 35609c510d0b4bcf0a4c9101ad97d1100711b10d dash_0.5.3-3.diff.gz 26636
+SHA256 8f70dfec8f1f1c72da38cec2f94b2ad6f9af825cd6ff3d945369a98fbd89eb07 dash_0.5.3-3.diff.gz 26636
+MD5 1a3cd6669459be4344ec55ec9d4914f8 dash_0.5.3.orig.tar.gz 207201
+RMD160 fd445535708868fe206852320eece58c3c2bbbaf dash_0.5.3.orig.tar.gz 207201
+SHA256 82aab2ff63e5fac4bff35c91222f735ec67551db86b5c3b3455ecc10e8889e53 dash_0.5.3.orig.tar.gz 207201
diff --git a/app-shells/dash/metadata.xml b/app-shells/dash/metadata.xml
index d31152aca840..8881475f99a8 100644
--- a/app-shells/dash/metadata.xml
+++ b/app-shells/dash/metadata.xml
@@ -6,4 +6,8 @@
<email>ka0ttic@gentoo.org</email>
<name>Aaron Walker</name>
</maintainer>
+ <maintainer>
+ <email>exg@gentoo.org</email>
+ <name>Emanuele Giaquinta</name>
+ </maintainer>
</pkgmetadata>