summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-11 16:06:45 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-11 16:06:45 +0000
commit3fac08e8a4a9abbd3b1243fa4d4c54f36d157972 (patch)
treeddf83346a208a244a4eea58f1818e0d35255a9b6 /app-shells
parentinit-script fixes (diff)
downloadgentoo-2-3fac08e8a4a9abbd3b1243fa4d4c54f36d157972.tar.gz
gentoo-2-3fac08e8a4a9abbd3b1243fa4d4c54f36d157972.tar.bz2
gentoo-2-3fac08e8a4a9abbd3b1243fa4d4c54f36d157972.zip
Drop forced libedit static linking #334693.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog3
-rw-r--r--app-shells/dash/dash-0.5.6.1-r1.ebuild16
2 files changed, 11 insertions, 8 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index f0fd9f477c2e..70bad8071f72 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
11 Sep 2010; Mike Frysinger <vapier@gentoo.org> dash-0.5.6.1-r1.ebuild:
+ Drop forced libedit static linking #334693.
+
+ 11 Sep 2010; Mike Frysinger <vapier@gentoo.org> dash-0.5.6.1-r1.ebuild:
Fix inverted static-libs depend #334693.
27 Aug 2010; Mike Frysinger <vapier@gentoo.org> dash-0.5.6.1-r1.ebuild:
diff --git a/app-shells/dash/dash-0.5.6.1-r1.ebuild b/app-shells/dash/dash-0.5.6.1-r1.ebuild
index 05d087e77ffb..349a7aba02ac 100644
--- a/app-shells/dash/dash-0.5.6.1-r1.ebuild
+++ b/app-shells/dash/dash-0.5.6.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.6.1-r1.ebuild,v 1.3 2010/09/11 15:39:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.6.1-r1.ebuild,v 1.4 2010/09/11 16:06:45 vapier Exp $
EAPI="2"
-inherit autotools eutils flag-o-matic
+inherit autotools eutils flag-o-matic toolchain-funcs
DEB_PV=${PV%.*}
DEB_PATCH=${PV##*.}
@@ -21,7 +21,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="libedit static"
-DEPEND="libedit? ( dev-libs/libedit static? ( dev-libs/libedit[static-libs] ) )"
+RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
S=${WORKDIR}/${MY_P}
@@ -35,11 +38,8 @@ src_prepare() {
# Fix the invalid sort
sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
- # Always statically link libedit in to ensure we always boot if it changes
- # which it has done in the past.
- local s="s/-ledit/-Wl,-Bstatic -ledit -Wl,-Bdynamic -lcurses/g"
- use static && s="s/-ledit/-ledit -lcurses/g"
- sed -i -e "${s}" configure.ac || die "Failed to sed configure.ac"
+ # Use pkg-config for libedit linkage
+ sed -i "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(use static && echo --static)\`:" configure.ac
# May as well, as the debian patches force this anyway
eautoreconf