summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-01-05 18:14:14 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-01-05 18:14:14 +0000
commit75c26ac536f1607c1059c29927407e4da305076b (patch)
tree7bb40323f7acbf2ff5ca967f373f123fbc678fab /app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild
parent2006.0 dev profile for ppc(32) (diff)
downloadgentoo-2-75c26ac536f1607c1059c29927407e4da305076b.tar.gz
gentoo-2-75c26ac536f1607c1059c29927407e4da305076b.tar.bz2
gentoo-2-75c26ac536f1607c1059c29927407e4da305076b.zip
Initial port. Ebuild contributed by Johannes Brügmann and Dominik Brugger or Bug #58565. Resolves Bug #58565.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild')
-rw-r--r--app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild b/app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild
new file mode 100644
index 000000000000..0091706f658c
--- /dev/null
+++ b/app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild,v 1.1 2006/01/05 18:14:14 mkennedy Exp $
+
+inherit scsh
+
+DESCRIPTION="Installation tool for the Scheme Untergrund Library"
+HOMEPAGE="http://lamp.epfl.ch/~schinz/scsh_packages/"
+SRC_URI="http://lamp.epfl.ch/~schinz/scsh_packages/${P}.tar.gz"
+
+LICENSE="as-is BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=app-shells/scsh-0.6.6"
+
+src_install() {
+ dodir $SCSH_MODULES_PATH
+ ./install.scm ${SCSH_LAYOUT_CONF} \
+ --bindir /usr/bin \
+ --force \
+ || die "./install.scm failed"
+}