summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-09-23 08:10:09 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-09-23 08:10:09 +0000
commitb0ef2d05c7390ff920361994222ac3679491e35c (patch)
treee6f91dbe4dab9cc2acc0c3bec47fdc025f74d1b6 /app-shells/ksh
parentclean older versions (Manifest recommit) (diff)
downloadgentoo-2-b0ef2d05c7390ff920361994222ac3679491e35c.tar.gz
gentoo-2-b0ef2d05c7390ff920361994222ac3679491e35c.tar.bz2
gentoo-2-b0ef2d05c7390ff920361994222ac3679491e35c.zip
attempting to fix #50000
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/ChangeLog6
-rw-r--r--app-shells/ksh/files/ksh-build-problems.diff11
-rw-r--r--app-shells/ksh/ksh-93.20040229.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index e540ec64c81c..2ce001534d4e 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/ksh
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.14 2004/09/14 17:59:09 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.15 2004/09/23 08:10:09 taviso Exp $
+
+ 23 Sep 2004; Tavis Ormandy <taviso@gentoo.org>
+ +files/ksh-build-problems.diff, ksh-93.20040229.ebuild:
+ attempting to fix #50000
14 Sep 2004; Gustavo Zacarias <gustavoz@gentoo.org> ksh-93.20040229.ebuild:
Stable on sparc
diff --git a/app-shells/ksh/files/ksh-build-problems.diff b/app-shells/ksh/files/ksh-build-problems.diff
new file mode 100644
index 000000000000..bc1a2456b868
--- /dev/null
+++ b/app-shells/ksh/files/ksh-build-problems.diff
@@ -0,0 +1,11 @@
+--- src/lib/libast/comp/conf.sh.orig Wed Aug 13 00:08:55 2003
++++ src/lib/libast/comp/conf.sh Wed Aug 13 00:10:55 2003
+@@ -266,7 +266,7 @@
+ -e 's,[ ].*,,' \
+ -e '/^[S_]/!d' \
+ `cat $tmp.f` 2>/dev/null |
+-sort -u > $tmp.v
++sort -u | grep -v _O_SC_CLK_TCK > $tmp.v
+ case $debug in
+ -d2) exit ;;
+ esac
diff --git a/app-shells/ksh/ksh-93.20040229.ebuild b/app-shells/ksh/ksh-93.20040229.ebuild
index 6005133eea9b..83ccc15dd396 100644
--- a/app-shells/ksh/ksh-93.20040229.ebuild
+++ b/app-shells/ksh/ksh-93.20040229.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.8 2004/09/14 17:59:09 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.9 2004/09/23 08:10:09 taviso Exp $
inherit ccc eutils flag-o-matic
@@ -36,6 +36,7 @@ src_unpack() {
# `package read` will unpack any tarballs put in place.
${S}/bin/package read || die
+ epatch ${FILESDIR}/ksh-build-problems.diff || die
}
src_compile() {